Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,455,955
Community Members
 
Community Events
176
Community Groups

Automate CSAT without Default Customer Notification Enabled

Hi all,

Really keen on implementing this automation (or finding a similar workaround) without having to utilize the default Request Resolved customer notification. Has anyone had any success with implementing the following Automation on Jira Service Management Cloud? 

https://confluence.atlassian.com/jirakb/how-to-send-csat-link-to-customer-using-custom-notification-via-automation-when-default-request-resolved-customer-notification-disabled-1086405958.html#:~:text=Provide%20feedback-,about,-this%20article

I believe I am getting hung up on the 'Send Web Request' step. I have followed the instructions and mirrored the details in the screenshots (except I have inserted a different web request URL and authorization code). I am curious about the following instruction that is captured in the screenshot for the 'Custom Data' field:

  "token": "test123",

Is "test123" supposed to be included in the Custom Data field or replaced by the API token?

When I attempt to use the 'Validate your web request configuration' option I get the following error:

{
  "errorMessages": [
    "There was an error parsing JSON. Check that your request body is valid."
  ]
}

Any insights from the community would be great appreciated. Thanks!

1 comment

Ajay _view26_ Community Leader Aug 01, 2022

Hi @Teddy Atkins 

Welcome to the Community!

test123 provided in the example is just some random payload added to the issue properties. 

You need to specifiy it with curly braces in the PUT custom data 

 {
"token": "test123"
}

 

This should make the JSON parsing error go away

Thank you for the quick response, Ajay. tes123 is entered in the custom data field as follows (matching the instruction in the How-to link), but am still getting the error.

{
"token": "test123",
"issueID": {{issue.key}}
}

The Response when attempting to validate is 'Response 400 Bad Request'

Nearly the same here: I get the response 401 "Unauthorized" because of Payload: "Basic authentication with passwords is deprecated."

 

Any resolution/workaround?

Comment

Log in or Sign up to comment
TAGS

Atlassian Community Events