Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Adding comment via 'Reply to customer' does not send email if an attachement is included

Matej Medvecký February 14, 2024

When a customer sends an email request, they receive an email confirmation from JIRA. When I add a public comment via the 'Reply to customer' button, the customer receives an email notification with the added comment. If the customer replies to the email, a new comment is added to the JIRA ticket. Everything works fine until I reply to the customer and include an attachment in the comment. As soon as there is an attachment (e.g., a PNG image or PDF), I can see the comment added in the JIRA ticket itself, but the customer does not receive an email notification. If I add another comment without an attachment, the customer again receives a notification.

Everything is set up correctly because notifications work in general. The only issue is with attachments. I have also checked the 'Customer notification logs,' and there is no log at all.

It is really annoying because I expect the customer to receive an email, and I am awaiting their response. After three days, we realize they have received nothing. Actually, I expect a notification to be sent out as soon as I add a comment. If not, I need to see a notification that there is an issue.

Any suggestions?

3 answers

1 vote
Mark Higgins
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
February 14, 2024

Hi @Matej Medvecký 

In the  Customer notifications, for your Project under the Attachment Security, what do you have the setting.

There are links from there that describe how this works.

Hope this helps.

Mark

0 votes
Matej Medvecký March 5, 2024

Anyone having any ideas how to solve it?

I also reported a bug to atlassian, but no response.

0 votes
Matej Medvecký February 18, 2024

Hi @Mark Higgins, thank you for your reply. I was looking for the Attachments Security in the Customer notifications of the Project, but i could find anyhthing related to Attachments. Then i found Attachment Permissions in the Permissions setting of the project. However, assigned Users/ Groups/ Project Roles are all configured correctly.

Let me add that the attachement which was added via the 'Reply to customer' can be seen in the issue itself as well as in the list of attachements of the issue. It is just the notification which was not sent out about it.

Do you have any ideas?

Thank you.

Matej

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
TAGS
AUG Leaders

Atlassian Community Events