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Why agents and project admins are not able to add customers to an organization or add organizations

Summary

Sometimes, users with the role of Project Administrator or Service Desk Agent in a service project are not able to manage/add organizations or add customers to an existing Organization. The option is not available or the user receives an error when adding an organization.

This causes confusion especially when the user is a project administrator.

Cause

This is because the users do not have the global permission to add organizations or manage customers in organizations.

The global setting in this case would be set to "Only Jira Administrators can manage organizations". This is shown in the screenshot below:

image-2023-3-15_12-12-46.png

Possible Solutions

Solution 1:

Allow agents to manage organizations and add customers to organizations by changing the setting as explained below:

  • Navigate to cog icon > Products.

  • From the Jira Service Management section on the left click on Configuration

  • In the section Organization Management, ensure that the option to allow Agents to manage organization is set to Yes, agents can add and remove organizations from projects, and add and remove customers from organizations.
  • Once this is set to Yes, an agent would also be able to add and remove organizations from projects, and add and remove customers from organizations

Solution 2:

  • If there is a need to restrict organization and customer management to administrators only, then a user who is a project administrator could be granted Jira administrator rights by adding the user to the 'jira-administrators' group

The setting is explained in the documentation linked below:

1 comment

Diet Bos July 3, 2024

Hello!

Although this article is really helpful, it does not describe what steps to take when this option is enabled, but when the agent is still not able to add an organization or a customer.

Regards

Diet

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