Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Jira Service Management is not processing email replies from O365

I'm Paulo, a Jira Service Management Support Engineer, and I'm here to share some information about common issues that we, Atlassian Support, face on a daily basis. As my starting point, there's nothing better than Jira Service Management Incoming Mail cases.

Quite often, we receive reports from customers saying that "replies to Jira Service Management Tickets are not being added as comments of the issue". Eventually, those replies are simply ignored due to Customer Permissions or result in duplicate tickets. However, I would like to cover a different case now.

There are a few cases where everything seems correct in the JSM side, and yet, when the customer replies to a Jira Service Management issue notification, their email isn't added as a comment of the ticket. After some investigation, we finally found a pattern in all of those cases, as all of the affected users seem to be using Office 365 Webmail to reply to Jira notifications.

O365?

Apparently, the “reply” action on O365 eventually disregards the "reply-to" mail header, and sends the email response to the actual email sender (the address in the *From* header) instead. By Googling, it's possible to see multiple reports of it across the Internet. Below you can find a couple.

Alright, but what does it have to do with Jira Service Management?

In a Jira Service Management project, you can configure two different addresses to receive requests by email: a Cloud one (owned by Atlassian) and a Custom one (owned by you). By default, those email addresses are not used to send Jira notifications. Instead, the regular jira@site.atlassian.net is used for that matter.

Because of that, Jira Service Management adds a “reply-to” mail header to customer notifications, indicating to the email client that the reply has to go to the email handler, and not to jira@site.atlassian.net. This is to guarantee that the message is delivered to the right address, as jira@site.atlassian.net will not process customer’s emails, as it validates the user’s license (replies from agents are successfully processed by jira@site.atlassian.net).

1.png

Fine, but my customers say that this only happens with Jira notifications!

Well, not everyone makes use of the reply-to header, and as all of the Jira Service Management notifications have it, it’s easy to assume that the issue only occurs in Jira. To rule that out, I’ve performed the following:

  1. In my personal Gmail Test account, I’ve created a rule to set my work email address as the “reply-to”, as per this article.

2.png

 

2. I’ve Sent a dummy message from my Gmail account to an O365 one.

3.png

 

3. The mail header contains the “reply-to” value set to my Atlassian account.

4.png

 

4. On the O365 side, the “reply-to” header was also present.

5.png

 

5. Regardless of the header, the “reply” button would still target the wrong email address instead.

6.png

My assumption here is that O365 saves the User’s name in the “From” address as a mail contact, and when the user hits “reply”, the application doesn’t read the mail header and targets the message to the mail contact instead. As Jira Service Management sends a message with the “Agent” name in the subject line, a new contact is cached with the site’s notification address.

An important note is that the issue actually takes a while to happen in O365. You might have to wait for a little before Outlook associates the user with Jira’s email address.

What can be done to prevent this?

I’m not an expert on O365, so I’m not sure if it's possible to do something on Outlook’s side. Instead, we can workaround this issue by setting Jira’s notification address to be the same as the Projects mail handler. That way, even with Outlook’s odd behavior, will still land on the Service Management project.

Please note that if you’re using a custom email handler to process Jira Service Management tickets, you’ll have to follow this documentation in order to use your domain to send Jira notifications.

  1. Go to your Jira Service Management Project and click on Project settings.

  2. On the left panel, look for Summary.

  3. Scroll down until you see the Notifications section.

  4. Click on the pencil icon and edit the email address, replacing it with the one by the email handler (find it on the Email requests section)

That should be all. I hope this helps you!

Cheers
Paulo Junior - Atlassian Cloud Support

 

6 comments

edwin vasquez
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
February 28, 2020

Thanks for sharing this! Im sure this will help a lot of people.

David Washburn March 9, 2020

We are getting a "DKIM validation failed for this domain" when we try to change the JSD notification email. Any thoughts on how we could resolve this?

Paulo Junior
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
March 11, 2020

Hi @David Washburn

If you're trying to use your own domain on the notification scheme, then you'll have to configure the DKIM and SPF settings on your DNS server, as per the following article: 

https://confluence.atlassian.com/adminjiracloud/configuring-jira-cloud-to-send-emails-on-behalf-of-your-domain-979428371.html

I hope this helps you out.

getquranic August 9, 2020

Thank you for this!

Any way to see the emails that WERE sent to jira@site.atlassian.net?

PS You guys should fix this on your end by default unless there's a reason not to.

lnelson1 November 15, 2021

Now, this works with the OOTB outbound notifications and replies, but how about the notifications sent from Automation? 

David Hubbard
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
December 17, 2021

This has saved me a lot of pain - Thanks for posting

Comment

Log in or Sign up to comment
TAGS
AUG Leaders

Atlassian Community Events