Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Portal characters encoding after upgrade to 4.0.0

Hi there! After last upgrade to JSD 4.0.0 I have a problem with characters encoding on Customer Portal. There is no polish characters, like ąśćł etc. Before upgrade there was no problem...

How can I fix it?

Screenshot_2019-02-14 07.49.23_NBpFbD.png

6 answers

1 accepted

4 votes
Answer accepted
Danson Atlassian Team Mar 04, 2019

Just to include important information, setting the encoding in setenv.bat was only applicable for JIRA instance startup with start-jira.bat 

Basically, the workaround was:-

  1. Stop JIRA Instance
  2. Configure below:-
    set JVM_SUPPORT_RECOMMENDED_ARGS=-Dfile.encoding=utf-8 -Dsun.jnu.encoding=utf-8
    • If you are starting JIRA from start-jira.bat, configure it in setenv.bat
    • If you are startup JIRA as a windows service, configure it follow windows service method
    • If you are using Linux server, configure it in setenv.sh.
  3. Take note, the above configuration was without quote (""). There are cases included quote causing JIRA instance unable to startup.
  4. Start JIRA Instance and perform checking

Sounds like a character collation issue with your database.  You will need to check the documentation for the database technology that you are using and see what the required character set is.  The process to correct the issue will be dependent on which database technology you are using. If you can post what database technology and version you're using, we should be able to point you to the right documentation to correct the issue.

I don't think that this is an issue with database because in other places in application there is no problem with polish characters...

 

My database is MSSQL 2017 with Latin1_General_CI_AI collation

Screenshot_2019-02-15 12.22.00_5hQDRC.png

Now I noticed if I refresh a page, there is no problem with encoding, but if I refresh it again, the problem is come back. 

Hello,

I can confirm the same issue after upgrade to JIRA ServiceDesk 4.0

Special characters (polish characters) are missing and replaced by ? in "rhombus"

My previous version of JIRA was 7.13, I am using MySQL 5.7 which use UTF-8


mysql> select * from propertystring where id in (select id from propertyentry where property_key='webwork.i18n.encoding');
+-------+---------------+
| ID | propertyvalue |
+-------+---------------+
| 10205 | UTF-8 |
+-------+---------------+
1 row in set (0.00 sec)

I noticed that this issue is only on customer portal view (ServiceDesk Agent view is valid without missing characters)

 

Here you can see this thread for Service Desk User (customer portal) view:

 

Service Desk issue wich polish characters.png

Here you can see this thread for Service Desk Agent view:

[IT-7173] Problem z pocztą - Google Chrome 2019-02-18 16.03.13 (1).png

Check the MySQL setup docs for MySQL 5.7. The correct character set for 5.7 should be utf8mb4. Atlassian has a doc on how to fix collation issues.  I'd make a backup of your database, then perform this action to set the character set correctly on each table, per the doc.

Dave,

I did what you recomended. without positive results.

The encoding problem is only when I open Customer Portal View with ticket from ServiceDesk Agent window.

Below you can see two windows on one screenshot as example.

TEST1 - ISE Service Desk - Service Desk - Google Chrome 2019-02-19 13.28.34.png

I wonder if you might be hitting a bug, then.  It might be a good idea to open an Atlassian support issue.

I noticed the same problem.

 

However, for me it only happens when I first load the page:

image.png

 

After activating a sub-link and returning to the home page, it comes back to normal:

image.png

 

That made me think we really hit a bug.

Hey! I've just fond the solution! 

In my case, characters encoding of the application was CP1250. I've changed this value using this solution (section Setting properties for Windows services via command line) using below options: 

-Dfile.encoding=utf-8 -Dsun.jnu.encoding=utf-8

 After restart, there is no problem with characters encoding :)

Hey Mateusz,

I tried to implement your solution, but without positive results. :-(

I did also some tricks with MySQL enconding for database according to Dave recommendation - no positive results too  :-(

-------------------------------------------------------------------------------

Some times the best solution is to start from begging so I tried to install JIRA ServiceDesk 4.0 (Core 8.0) from scratch.

  1. I droped jira database and create it from scratch like is described in this Connecting Jira applications to MySQL 5.7
  2. Then I imported backuped database (exported from production enviroment which works on JIRA 7.10)

It didn't resolve my problems with encoding custom portal but I noticed some new thing.

The problem is with encoding only when I try to open Customer Portal View (window) from ServiceDesk Agent portal like on screen below:

[IT-7740] TEST1 - Lyreco JIRA 8.0 - Google Chrome 2019-02-19 13.27.52 (1).png

Do you have any ideas what can cause this issue?

Be sure if your characters encoding is stetted to UTF-8 going to system info and checking System Encoding. In my case I've done one more think : I've edited the setenv.bat file using this line:

set JVM_SUPPORT_RECOMMENDED_ARGS="-Dfile.encoding=utf-8 -Dsun.jnu.encoding=utf-8"

Try it and then restart JIRA instance. Maybe that change will help you. 

Still the same problem with encoding for customer portal view.

Anyway thanks for help.

Hi Mateusz,

 

I have also tried out your solution, without luck.

But thank you for sharing it anyway.

Gosh... I am wondering why above solution have worked in my case...

This solution is worked for me too.
Jira is running on Linux. Database - PostgreSQL

I have created an issue for this problem: https://jira.atlassian.com/browse/JSDSERVER-6258

I got the same problem but in 3.16.1 version. Jira and Jira Service desk is installed on the same instance. There is only problem with encoding polish characters in service desk portal. I suppose that this issue has been showed up after some upgrade Jira/JiraSD.2019-04-05_15h42_29.png2019-04-05_15h42_46.png

Hello Community,

I have exactly same problem, did someone found solution already ? :)

Thank you, Michal

Hi Michall.

First you need to doo is identify how you start your aplication. For example in my case I use Windows service. After that you need to configure the system properties when starting 

1 - Identify the name of the service that JIRA is installed as in Windows ( Control Panel > Administrative Tools > Services ):

1.png
In the above example, the SERVICENAME is: JIRA231112155942

2. Open the command window from Start >> Run >> type in 'cmd' >> Enter
3. cd to the bin directory of your JIRA application installation directory.
4. Run:
5. tomcat8w //ES//%SERVICENAME%

In the above example, it would be tomcat8w //ES//JIRA231112155942

3.png

Click on the Java tab to see the list of current start-up options:

2.png

7. add this option in "Java option":

-Dfile.encoding=utf-8
-Dsun.jnu.encoding=utf-8

Hello, 

I am a colleague of Michal Nedela.

We are starting JIRA as a win service. I followed the steps above and added -Dfile.encoding=utf-8 and
-Dsun.jnu.encoding=utf-8 to Java options. After that we were unable to Startup JIRA again, even after rebooting JIRA server - we get Error 1067: The process terminated unexpectedly. We are running Windows Server 2012 R2, JIRA 8.1.0, Java v. 8 update 111 (build 1.8.0_111-b14), database MSSQL 2012.
Can be the reason low memory? As you can see in picture, we have allocated max. memory pool for Java 2048 MB and Tomcat8w process uses the same amount. Our virtual server has 8192 MB.

 

Tomcat-Java-properties.pngTomcat-memory.png

Hello,

 

Just checked those memory settings in my dev server and Jira starts fine with it.

Please check catalina.[date].log, it should contain the error why it failed to start.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Asked in Jira Service Desk

Calling all Insight users, we need your help!

Hello Insight users,  As part of our (Mindville's) acquisition by Atlassian, our training team is looking to build some new Insight training materials. It would really helpful if you can ...

52 views 0 0
View question

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you