Link types in Service Desk Edited

When I link issues in Service Desk, I have to choose between several connection types:

  • Duplicates
  • Is duplicated by
  • Clones
  • Is cloned by
  • Blocks
  • Is blocked by
  • Causes
  • Is caused by
  • Relates to

Most of then seems redundant or unnecesary unidirectional. "Clones" and "is cloned by" seems the same for me. The same for "duplicates" and "clones".

What are the meaning of all of them and the differences?

 

 

1 answer

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The bi-directional nature of links is absolutely not redundant.

Consider them in a simple sentence.  Let's say I've got issues ABC-123 and DEF-456. 

With non-directional links, you'd only be able to say "ABC-123 is linked by 'Block' to DEF-456".  You cannot tell from that sentence whether ABC-123 is blocked by DEF-456 or DEF-456 is blocked by ABC-123.   The same happens for "clones/is cloned by" - which one is the original if you just say "clone link"?  Or "duplicates/is duplicated by" - which one is the duplicate if you just say "duplicate link"?

In the example I just gave, have a look at the issues  ABC-123 and DEF-456.  When you look at the link on ABC-123, you will see "is blocked by DEF-456".  But when you look at the link on DEF-456, you will see "blocks ABC-123".  There's only one link, but it's giving you important information about which one is which.

Note that JIRA link types are defined by a name, and then two displays, one for each direction.  So your list above is actually only five types of link, but it's showing you the directional pairs because they matter.  (Relates-to is the exception - it's still bi-directional technically, but the language makes it one directional, so you only see one entry)

So, on your list, the link types are generally used for:

  • Clone - an issue was deliberately copied within JIRA
  • Duplicate - someone raised a new issue, and someone then saw that we already had that issue raised, so we want to show the people who raised or viewed the new one that we already have it on the list
  • Blocks - an issue prevents another one progressing
  • Causes - an issue has caused another issue
  • Relates to - a handy catch-all.

If you don't like the list, that's not a problem.  Your admins can add more link types, remove any of the above (I strongly recommend keeping relates-to if nothing else, but all the others are generally useful as described), or rename the link types and/or displays.

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