Connect to Office 365 mailbox

Hi, I wonder to know how to configure email channel for office 365 mailbox since Microsoft give that information:

Server: smtp.office365.com

Port 587 (recommended) or  port 25

TLS/start TLS Enables

I tried many way but didn't connect whatever the configuration I made

Thank you

1 answer

0 votes

Hi Patrice,

  • What kind of errors do you see in the UI or in the logs when you try to configure Office 365 in JIRA?
  • Is this a Cloud instance or Server instance?

There is an article titled A3 BAD User is authenticated but not connected error message when using JIRA with Office365 that may help.  If this is a Server instance take a look at the logs and see if you see something similar:

2014-09-12 07:40:48,051 ERROR [365 IMAP] QuartzScheduler_Worker-3 ServiceRunner    Help Desk Handler[10100]: Messaging Exception in service 'com.atlassian.jira.service.services.mail.MailFetcherService$MessageProviderImpl' when getting mail: A3 BAD User is authenticated but not connected.
javax.mail.MessagingException: A3 BAD User is authenticated but not connected.;
  nested exception is:
 com.sun.mail.iap.BadCommandException: A3 BAD User is authenticated but not connected.
 at com.sun.mail.imap.IMAPFolder.open(IMAPFolder.java:961)
 at com.atlassian.jira.service.services.mail.MailFetcherService$MessageProviderImpl.getAndProcessMail(MailFetcherService.java:254)
 at com.atlassian.jira.service.services.mail.MailFetcherService.runImpl(MailFetcherService.java:401)
 at com.atlassian.jira.service.services.file.AbstractMessageHandlingService.run(AbstractMessageHandlingService.java:257)
 at com.atlassian.jira.service.JiraServiceContainerImpl.run(JiraServiceContainerImpl.java:61)
 at com.atlassian.jira.service.ServiceRunner.execute(ServiceRunner.java:48)
 at org.quartz.core.JobRunShell.run(JobRunShell.java:195)
 at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)
Caused by: com.sun.mail.iap.BadCommandException: A3 BAD User is authenticated but not connected.

If you do see this and you're using a shared mailbox the current workaround is to use POP3 instead.  There are some comments that purport to have IMAP working fine by resetting the Shared mailbox user's password or adding java parameters.

If this is the issue you're running into take a look at both of these Suggestions and see which one works best for you.


Cheers,

Branden

Suggest an answer

Log in or Join to answer
Community showcase
Teodora [Botron]
Published Thursday in Marketplace Apps

Jira Inferno: The Nine Circles of Jira Administration Hell

If you spend enough time as a Jira admin - whether you are managing a single, mid-sized instance, a large enterprise one or juggling multiple instances at once - you will eventually find yourself in ...

433 views 1 14
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot