It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

AJS.contextPath() is not here. Please use require("servicedesk/util/context-path")

When a user attempts to log a service desk issue, the ajax wheel spins and nothing happens. No issue is created. Upon using the js console, I can see an error thrown: 

 

AJS.contextPath() is not here. Please use require("servicedesk/util/context-path")
POST http://***.*********.com:8080/servicedesk/customer/portal/1/create/12 400 (Bad Request)

 

With the following trace details:

 

c.support.ajax.c.ajaxTransport.send @ batch.js?locale=en-US:180
c.extend.ajax @ batch.js?locale=en-US:175
e @ batch.js?locale=en-US:5058
h.extend.post @ batch.js?locale=en-US:5059
a.Model.extend.save @ batch.js?locale=en-US:4745
h.extend.onSubmit @ batch.js?locale=en-US:4017
c.event.dispatch @ batch.js?locale=en-US:83
c.event.add.g.handle.h @ batch.js?locale=en-US:74

 

 

My current version info is as follows:

JIRA - 6.3.15 BUILD 6346

Service Desk - 2.3.6

 

 

 

2 answers

1 accepted

0 votes
Answer accepted
Boris Berenberg Community Leader Jun 24, 2015

Do you have any custom add-ons which may be causing this? I see that customers have hit this problem in the past when doing development work: https://answers.atlassian.com/questions/281635

Do you have a date picker on the UI? I am seeing similar reports at: Custom field based on the type "Date Picker" doesn't function in Jira Servicedesk OnDemand

Is JIRA sitting behind a caching proxy such as Cloudflare? Similar report at: https://answers.atlassian.com/questions/9876619

If the answer to all of these questions is no, I would try restarting JIRA to ensure that something didn't get messed up in the caches. If the issue persists, then you should disable minification: https://developer.atlassian.com/confdev/development-resources/confluence-developer-faq/how-to-switch-to-non-minified-javascript-for-debugging and then reproduce the issue, and capture a HAR file https://confluence.atlassian.com/display/KB/Generating+HAR+files+and+Analysing+Web+Requests and provide it to us in a support ticket to review: https://support.atlassian.com/

I updated all of the plugins, re-indexed, and restarted the Jira server and the issue went away.

Found out a similar issue was happening from the Find Duplicates Plugin in our system on JIRA 6.4.12. Disabled this plugin and Customer portal is up and running again

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Jira Service Desk

Tell us how you've implemented Change Management

Hello Community 👋, I'm a product manager at Atlassian, looking at improving change management capabilities across our products. In particular, we're looking at bridging the gap between Dev & ...

336 views 0 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you