Question in creat a new issue by workflow post-function through HQL link add-on

I want copy the description in parent issue to link issue,the parent issue description include URL like this 

http://wx.yuan.com/yqb-wx-app//app/info/infoDetail.htm?infoid=dbe641cbac2c43ab938cbe6dbea839d6&parkId=null&from=timeline&isappinstalled=0

but find errors message in logs like this

2016-08-16 16:00:00,937 http-nio-8080-exec-10 ERROR jira 960x118142x1 1x7y1xj 172.16.135.41 /secure/CommentAssignIssue.jspa [c.a.jira.workflow.OSWorkflowManager] Caught exception while attempting to perform action 61 from workflow 61565 on issue 'BAOLS-1642'
java.lang.NullPointerException
at com.herzum.jira.plugins.genericlinker.manager.HQLManagerImpl.createIssue(HQLManagerImpl.java:3890)
at com.herzum.jira.plugins.genericlinker.manager.HQLManagerImpl.escalateIssue(HQLManagerImpl.java:1665)
at com.herzum.jira.plugins.genericlinker.wf.EscalateIssue.execute(EscalateIssue.java:70)
at com.opensymphony.workflow.AbstractWorkflow.executeFunction(AbstractWorkflow.java:1050)
at com.opensymphony.workflow.AbstractWorkflow.transitionWorkflow(AbstractWorkflow.java:1446)
at com.opensymphony.workflow.AbstractWorkflow.doAction(AbstractWorkflow.java:564)
at com.atlassian.jira.workflow.OSWorkflowManager.doWorkflowActionInsideTxn(OSWorkflowManager.java:825)
at com.atlassian.jira.workflow.OSWorkflowManager.doWorkflowAction(OSWorkflowManager.java:786)
at com.atlassian.jira.bc.issue.DefaultIssueService.transition(DefaultIssueService.java:430)
at com.atlassian.jira.web.action.issue.CommentAssignIssue.doExecute(CommentAssignIssue.java:167)
... 1 filtered
at com.atlassian.jira.action.JiraActionSupport.execute(JiraActionSupport.java:63)
... 7 filtered
at javax.servlet.http.HttpServlet.service(HttpServlet.java:725)
... 17 filtered
at com.idalko.jira.plugins.igrid.WebResourceIncludeFilter.doFilter(WebResourceIncludeFilter.java:160)
... 41 filtered
at com.atlassian.greenhopper.jira.filters.ClassicBoardRouter.doFilter(ClassicBoardRouter.java:59)
... 155 filtered
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
at java.lang.Thread.run(Thread.java:745)

1 answer

1 accepted

Hello,
Could you please let me know the installed Jira and add-on versions?
Furthermore, could you please check if the target project/issue type expects a value for a required field and no default value has been setup?

Sincerely,
Antonella

hi hello!

JIRA :7.0.10

Herzum Quick Linker:4.7.1-JIRA-7.0-7.1

I already check the target issue type expects a value for a required field already has been set default value .

I try some times , if the parent issue description doesn't include URL address link,creat the new issue is  succeed,but only include URL address link ,the created action fail.

Hi Colincy,

The bug has been reproduced case of the Description field includes the character '&' and the field is required on the target issue type.

My only perplexity stays in the logs not addressing to the same error.

Could you please update the add-on version to the latest and let me have new logs at my email address antonella.capalbo@herzum.com.

Furthermore, could you please confirm the mentioned scenario?

Sincerely,

hi,Antonella Capalbo after updating the latest version, the problem is solved.thank you very much!

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Wednesday in Jira

Join our webinar: How 1B+ feature flag events helped us build the new Jira

Every time you release software, there's a bit of risk – that there's a bug, that something breaks, or that the feature doesn't resonate with customers. Feature flagging helps make high stakes s...

94 views 0 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you