Jira startup failed - plugins not started

Hi

After a server reboot, JIRA won't start anymore. I get the following message:

JIRA Startup failed

The following plugins are required by JIRA, but have not been started:

  • JIRA Project Config Plugin (com.atlassian.jira.jira-project-config-plugin)
  • Atlassian JIRA - Plugins - Global Issue Navigator (com.atlassian.jira.jira-issue-nav-plugin)
  • Atlassian JIRA - Plugins - Quick Edit Plugin (com.atlassian.jira.jira-quick-edit-plugin)
  • Atlassian JIRA - Plugins - REST Plugin (com.atlassian.jira.rest)

 

Here is an extract of the log:

JIRA Build : 7.1.8#71012-sha1:d83491778ddf5df967f3c738fa396f8b341ab597
Build Date : Mon Jun 13 00:00:00 CEST 2016
JIRA Installation Type : Standalone
Application Server : Apache Tomcat/8.0.32 - Servlet API 3.1
Java Version : 1.8.0_74 - Oracle Corporation
Current Working Directory : /volume1/homes/jira/bin
Maximum Allowable Memory : 1820MB
Total Memory : 656MB
Free Memory : 260MB
Used Memory : 396MB
...
JVM Input Arguments : -Djava.util.logging.config.file=/volume1/homes/jira/conf/logging.properties -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Xms384m -Xmx2048m -Djava.awt.headless=true -Datlassian.standalone=JIRA -
Java Compatibility Information : JIRA version = 7.1.8, Java Version = 1.8.0_74

___ Java System Properties _________________

atlassian.plugins.enable.wait : 300
atlassian.standalone : JIRA

...

2017-03-10 08:50:28,028 JIRA-Bootstrap ERROR [c.a.p.osgi.factory.OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.jira-core-project-templates' : Unresolved constraint in bundle com.atlassian.jira.plugins.jira-core-project-templates [40]: Unable to resolve 40.0: missing requirement [40.0] osgi.wiring.package; (osgi.wiring.package=com.atlassian.jira.blueprint.api) [caused by: Unable to resolve 107.0: missing requirement [107.0] osgi.wiring.package; (osgi.wiring.package=com.atlassian.jira.plugins.workflow.sharing.importer.component) [caused by: Unable to resolve 106.0: missing requirement [106.0] osgi.wiring.package; (osgi.wiring.package=com.sysbliss.jira.plugins.workflow.util)]]. This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see https://developer.atlassian.com/x/mQAN

2017-03-10 08:50:28,029 JIRA-Bootstrap WARN [c.a.plugin.impl.AbstractPlugin] Unable to enable plugin 'com.atlassian.jira-core-project-templates'


I have already tried all the hints in https://confluence.atlassian.com/jirakb/troubleshooting-jira-startup-failed-error-394464512.html but with no luck.

 

Any help would be greatly appreciated !


2 answers

Hey Benoit,

Please try these steps

  1. Stop JIRA Service

 

Browse through JIRA Data Directory (C:\Program Files\Atlassian\Application Data\JIRA\plugins)
Make sure you enable to see hidden folders as .osgi-plugins and .bundled plugins will be there as hidden

 

If its a Linux environment, you can do

ls -al /var/atlassian/application-data/jira/plugins
rm -r .osgi-plugins
rm -r .bundled-plugins

 

3. Remove / Archive Old Application log files

 

mv /var/atlassian/application-data/jira/log/atlassian-jira.log /home/jira

 

 

 

This is to make sure you get a fresh and new log after starting JIRA.

 

4. Start JIRA Service.

 

You can also foreground JIRA Service to see what exactly is the error monitoring catalina.out

 

 

 

cd /opt/atlassian/jira/bin
./start-jira.sh -fg
For Windows
use Command Prompt 
cd <JIRA Install Directory>\bin
start-jira.bat /fg

 

 

 

Once you get info on logs, if it was run as foreground process, stop JIRA , fix the issue or post the log file here so we can better troubleshoot and later you can start JIRA Service (background)

 

 

Hey,

 

Thanks for your answer.

I had already tried this but with no success.

 

I've just installed the last JIRA software version (7.3.2) - I was previously using 7.1.8 - and it fixed my issue !

 

Gonchik Tsymzhitov Community Champion Jan 18, 2018

Hello Beoit, 

Have you fix it? 

Just interesting what the cause it.

 

Cheers,

Gonchik Tsymzitov

Suggest an answer

Log in or Join to answer
Community showcase
Teodora [Botron]
Published Thursday in Marketplace Apps

Jira Inferno: The Nine Circles of Jira Administration Hell

If you spend enough time as a Jira admin - whether you are managing a single, mid-sized instance, a large enterprise one or juggling multiple instances at once - you will eventually find yourself in ...

240 views 0 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot