Cant start JIRA after upgrade to JIRA 7.0.0 from JIRA 6.4.12

I cannot start JIRA 7.0.0 or 7.0.10 with the same error.

Trying to upgrade from JIRA 6.4.12 with ALL PLUGINS DISABLED

But getting the same error every time when I try access it thru web:

 

JIRA Startup Failed

Error occurred while starting component 'com.atlassian.jira.event.DefaultListenerManager'. caused by: java.lang.NoSuchMethodError: com.atlassian.jira.issue.fields.CustomField.setDescription(Ljava/lang/String;)V

 

catalina.out log:

  1. 2016-02-07 05:30:06,387 localhost-startStop-1 INFO      [c.a.jira.startup.LauncherContextListener] Memory Usage:
  2.     ---------------------------------------------------------------------------------
  3.       Heap memory     :  Used:  972 MiB.  Committed: 8879 MiB.  Max: 8879 MiB
  4.       Non-heap memory :  Used:  189 MiB.  Committed:  204 MiB.  Max: 1264 MiB
  5.     ---------------------------------------------------------------------------------
  6.       TOTAL           :  Used: 1160 MiB.  Committed: 9083 MiB.  Max: 10143 MiB
  7.     ---------------------------------------------------------------------------------
  8. 2016-02-07 05:30:06,621 localhost-startStop-1 ERROR      [c.a.j.web.dispatcher.JiraWebworkActionDispatcher]
  9.  
  10.     ******************************************
  11.     JIRA startup failed, JIRA has been locked.
  12.     ******************************************
  13.  
  14. 07-Feb-2016 05:30:06.656 SEVERE [Catalina-startStop-1] org.apache.catalina.startup.HostConfig.start Unable to create directory for deployment: /home/jira/main/conf/Catalina/localhost
  15. 07-Feb-2016 05:30:06.671 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["http-nio-8080"]
  16. 07-Feb-2016 05:30:06.682 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in 175913 ms
  17. 2016-02-07 05:30:20,091 Modification Check:thread-1 INFO      [c.a.jira.startup.JiraStartupLogger]

 

I found that there is something wrong with com.keplerrominfo.jira.plugins.databasecf:

 2016-02-07 05:29:56,218 FelixDispatchQueue ERROR      [c.a.p.o.container.felix.FelixOsgiContainerManager] Framework error in bundle com.keplerrominfo.jira.plugins.databasecf

 

but got no clue how to fix it. Also I can't find any documentation for migration steps before upgrading JIRA from 6 to 7. Please help.


 

See full log message with exceptions is here:

http://pastebin.com/zGFwXqDU

2 answers

1 accepted

0 vote

>Trying to upgrade from JIRA 6.4.12 with ALL PLUGINS DISABLED

That might be the problem - some add-ons need to be there.  However, you might want to try complete removal of the add-on as well, not just disabled, but uninstalled.

Yes, I have deinstalled most of the useless add-ons and upgrading went smoothly.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Wednesday in Jira

Join our webinar: How 1B+ feature flag events helped us build the new Jira

Every time you release software, there's a bit of risk – that there's a bug, that something breaks, or that the feature doesn't resonate with customers. Feature flagging helps make high stakes s...

107 views 0 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you