Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,362,537
Community Members
 
Community Events
168
Community Groups

Sorting of columns in the "Page property report" macro no longer works for individual users

Edited

The sorting of columns in the "Page properties report" macro by taping on the column headline no longer works as of Confluence Update 7.13.1. This still worked before the update. 

Interestingly, the problem only occurs with individual users. 

And if an affected user logs out of Confluence and logs back in as admin on the same PC, the sorting of columns in the "Page property report" macro works again.
So it's not a browser-dependent problem. Logged in as admin with different browsers, it worked. As an affected user, however, it did not work with any browser (Edge, Firefox, etc.)

It's an additional Problem to the Question "Page Properties Report not sorting first item in list; first item "sticky"".

Seems also like a mistake to me...
Can someone report something about it (existing issue, problem solution)?

1 answer

0 votes
Dave Mathijs Community Leader Jan 10, 2022

Hi @Sebastian Spitzer , what data types to these columns contain? Text, user mention?

I found bug CONFSERVER-59179 which may be related.

Hi @Dave Mathijs , 

I see a connection between the default in the "Page properties report" macro - "Sort by" parameter and the content in the affected column, which is "Sort by".
I had donated a repro case in the article https://community.atlassian.com/t5/Confluence-questions/Page-Properties-Report-not-sorting-first-item-in-list-first-item/qaq-p/1693127.

It gives the impression that it is the contents of the affected column in the combination of macro and text. Macro and text are treated and interpreted differently when sorting via the properties with the "Sort by" parameter.

The issue https://jira.atlassian.com/browse/CONFSERVER-59179 describes it similarly but a little more differentiated, as in my repro case. Basically it seems to be the right issue.

It would be possible that this contribution is equivalent to the contribution https://community.atlassian.com/t5/Confluence-questions/Page-Properties-Report-not-sorting-first-item-in-list-first-item/qaq-p/1693127. The reference to the issue https://jira.atlassian.com/browse/CONFSERVER-59179  is correct in my opinion.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events