Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Page Properties report does not find some pages labelled "requirements"

Some confluence pages with the "requirements" label do not appear in a page properties report configured to show all pages with the requirements label.

Eg, Page A and B have a page properties macro instance on them (with say fields field_a, field_b) and the "requirements" label applied. Page C has a Page Properties Report macro configured to show properties from pages with the "requirements" label.  Surprisingly Page A and its fields do not appear in the page properties report, whereas Page B does.  Perhaps more surprisingly, deleting the requirements label on Page A and re-applying it clears the problem (now both pages show up in the page properties report).  Persistent issue is figuring out how pages get into this non-working state.

Using the Confluence GUI, pages that aren't showing up in the page properties report do have the requirements label at their bottom right as expected.  Using the REST API also shows that the pages in question have the requirements label.  Also using the REST API to expand the page content shows that the CQL field driving the page properties report has a query of the form (eg, lablel="requirements" and name ~ XXX").

Searching for pages labelled with "Requirements" doesn't produce the problematic pages when the page properties macro is not working for them - but as noted above the labels appear on those pages when viewed through the GUI.

Can't think of a reason why seemingly replacing the existing "requirements" label with itself on the page fixes the issue, nor why it occurs in the first place.

Any suggestions welcome :-)

14 answers


The Page Properties Report macro appears to have been broken for a very long time. In fact, it has been almost four (4) years since this thread was started. Yet, there has been no meaningful response from Atlassian and this continues to be an issue for some customers.

Does Atlassian recognize this as a bug? If so, when will it be fixed?

If not, is there a work-around or another feature than provide the desired result?

When can we expect some response from you? Your customers are unable to find a suitable solution on our own...

Stefan Kleineikenscheidt _K15t_
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jun 23, 2022

Since their introduction around 2011 Page Properties have never been a big focus of Atlassian, even though many users heavily rely on it. It's a shame, because Page Properties could have been so much more useful for everyone, if it had been improved, e.g. with typed fields.

That's why we (K15t, Marketplace Partner) finally decided to build an app called Orderly Databases for Confluence Cloud that implements something like page properties. We've released it end of last year, and it is now in a very useable state (although we have a team continuously improving it).

This is how it looks to edit an entry linked to page:


If you want to learn more, here is the announcement:

I know this is an old issue, but I thought I'd drop some breadcrumbs for the next person to see this page.

This might be caused by a problem with Confluence's search index. One way to fix it is to rebuild the search index.

If removing and reapplying the label fixed it, perhaps this behaviour is enough for your search index to catch up and "notice" the page.

See also Page not showing in any search/report/tree

Also having a similar issue. The pages clearly show the label but are not showing up in the page properties report. Simply editing the page, CHANGING NOTHING and publishing is enough to cause them to show up in the report. This is problematic for us as we're using this macro to collect release documents and sometimes they just don't show up, then we have to go modify each page to get them to display in the report. Requires a manual workaround which this report is supposed to help replace.

Like # people like this

We have the same problem, but we only have to view a missing page for it to start appearing in the report. Slightly easier, but unfortunately, that means manually visiting 350+ pages every time we refresh that catalog, so still not a great (admin) user experience.

Anyone know if the Confluence team is working on this bug?

@Amanda Pfeifer
@Melanie Albrecht 

I am facing a similar issue and have reported it -

whether it got fixed for anyone? any suggested workaround for this?

Yes this is an issue for me also

Still an issue! Does anyone have a good workaround?

Not to my knowledge, @Christina Petersen 

This seems to be the solution.

Adding a "page properties" macro (you can mark it as "hidden" so it doesn't show in the page) and an empty table with two columns inside it did the trick.



Would you be able to elaborate on this?

Amandeep Singh Dhindsa
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Nov 19, 2023

The template should contain the page properties and a table inside it.

Experiencing the same issue on Confluence Cloud instance. Page Properties Report is only showing some of the page with the selected Label. The list of pages that appear in the PPR changes from time to time.

The strange thing is that, to my knowledge, this didn't occur until today after I'd added a about 40 new pages with the specified Label. I have a suspicion that this is related to the number of pages bearing the Label.  A PPR selecting on a label that is on fewer pages (i.e., a few dozen or less?) works as expected; for more more pages (i.e., more than a few dozen?), pages are dropped.


I use Page Properties and Page Properties Report macros extensively in our Confluence pages.

I have faced the similar issue and reported it -

whether it got fixed for anyone? any suggested workaround for this ?

We had to shut down/restart Confluence, flush all the caches, and rebuild the index from scratch (not just refresh/rehydrate). That fixed that instance of the problem but it has since re-occurred multiple times. No word of a fix for preventing the issue. My money is on root cause being something with the object (eg, page and label) mapping caches. 

Like Hitesh.Kumar likes this

very sad to hear this :( I think JIRA should have bug opened for this and fix it as critical / blocker for clients asap. 



@Hitesh.Kumar , sadly, the issue you created is not visible... 

I'm having the same problem in our Cloud instance, labeled pages aren't showing up as expected.

Upvoting! ++++

This is really annoying issue.


I have even tried to add a completely new label and build a new properties report  and seems like confluence completely ignores those absent pages even in the new report, though other pages when adding this new label are shown in the report instantly.

Please fix.

(Temporary) Solution

This seems to be some kind of pagination error. If you increase the  "Number of items to display" to a value high enough, that all entries are shown, it works for me.

Of course, this is quite annoying, since you'll have very large tables - but it shows the data correctly (for me)

Is there a bug posted on the Atlassian Confluence project? i would like to vote for the fix. It's really annoying as page reporting macro is used for reporting to the high management... No need to explain further i guess.

See the first reply from @Hitesh.Kumar above. The Jira Cloud Bug -- which remains unfixed -- can be found at

We have a similar issue on the coud version of CONFL. is there an approach for an workaround? 


Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events