Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Page not showing in any search/report/tree

I have created a new page in Confluence, starting from the Blank template. Afterwards, I moved it from my personal space to another space using the 'Move' function and added some labels to make it show up in the 'meeting-notes' list.

Although this page does show up as a Child-page in the left-hand nav pane, it does not come up in any search results (e.g. when creating a link, or when using the Report Table or Page Tree macros...)

There is no restriction on the page itself, but there is on the Space it has been moved to.

Please help! Thanks.

4 answers

1 accepted

0 votes
Answer accepted

How about try checking on your indexes? Have you tried flushing it all? Start your investigation with indexes first. A good troubleshooting page to try and further diagnose on indexing problem would be - https://confluence.atlassian.com/display/CONFKB/Searching+and+Indexing+Troubleshooting

Thank you for your answer.

I also stumbled upon that page as I was also thinking in that direction, but unfortunately I don't know how to do this flushing? I am a user, not an admin...

Thanks for any hints on how to do this.

A newly created page wasn't appearing for me. It was within the tree structure under the main page of the space, but still wasn't appearing. I suspect a re-index may have fixed this, but first I tried moving the page to the same parent page it was already under, and then it appeared in the tree.

Oh, if you're a normal end user then you do not have that permission. You are right... how about try contacting your admin? :)

I went to the admin, and he rebuilt the indexes. But unfortunately it didn't help.

Any other ideas? Thanks.

I might be wrong, but it looks like the problem is even more severe than I thought.

None of the new pages I create appear in any search! I tried renaming, moving to another space, etc... Nothing works.

Thoughts?

OK. In the meantime our admin was able to solve the problem. In the end it indeed was related to the indexes, but Confluence needed a restart before the Rebuild would work. It was probably related to a memory issue... That's anyway for the help!

No problem, glad to know that your problem is now resolved. :D

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

342 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you