Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,295,937
Community Members
 
Community Events
165
Community Groups

Jira Issue Macro not showing custom field value in Confluence Cloud

I have created some custom fields in JIRA and when creating dashboard using insert JIRA macro, results/values of those fields are not shown in Confluence. 

 

Version we are using is : Confluence 1000.0.0-188a34193d74

I already found some issues related and those were fixed in confluence server. Confluence cloud still has these issues. 

https://community.atlassian.com/t5/Confluence-questions/Jira-Issue-Macro-not-showing-custom-field-value-in-Confluence/qaq-p/1495475

2 answers

Has this been solved for a paragraph of text? I'm experiencing the same issue. The field shows up in the table but there are no values coming through. It seems like every time I want to take advantage of something that should work between Confluence and Jira there is always a bug preventing me from being able to take full advantage. I have a text field on user story for "Test Scenario" and I want to create a table of "Test Scenarios" for a given story, epic, etc... Only the #@$%@#$'ing field values don't come through. So aggregating a list of test scenarios on tickets in Jira can't be done the way I'm trying to do it. So we're back to writing them out in 2 places I guess. 

 

Screen Shot 2022-02-07 at 10.32.35 AM.png

0 votes

Hello @ambujp ,

As you discovered in the alternate thread there are still some field types encountering issues in the Jira issue macro, and I want to make sure that the field type you are encountering an issue with is correctly being tracked for follow-up.  

What field type are you using for your custom fields, I know there are a few bugs currently with various field types, as one example:

  • CONFCLOUD-71741
    • Custom field types from Tempo are not populating in Jira issue macro

Regards,
Earl

Same issue here, using a Dropdown custom field type on Cloud Jira instance.

Also, it seems this behavior is changing periodically, sometimes rendering every custom field value as it should, but sometimes shows nothing about the values, without any macro change at all.

Can you help please?

Thanks.



@Earl McCutcheon Sorry for delay in reply. My issues was automatically solved after 2-3 hours.

 

Just guessing what might have caused this issue.

- When we create custom fields in JIRA they are stored in some database (say new_custom_field_db). 

- When we create JIRA dashboard in confluence, it fetches value of fields from other database (say master_custom_field_db). 

new_custom_field_db  syncs with master_custom_field_db every 2-3 hours. 

So initially when custom fields are created in new db but not synced with master db, values are not shown in dashboard. After syncing, they are shown properly. 

Hello @ambujp ,

No worries about the delay, thanks for the confirmation, and I'm glad to hear the issue was resolved.  I believe you are correct in your assumption on the delay in synchronization between Jira and Confluence most likely due to a load balancing operation during some high usage operation occurring either on the Jira or Confluence side.

For a little more info on what I suspect is the issue here is that in Confluence the Jira issue macro will pull from a cached data source.  The cache has a time to live (TTL) variable.  The default value is 5 minutes, however, there is some load balancing that takes place depending on the system load and the TTL can be delayed to rely on caching under heavy usage time periods.  If the same Jira Issue Macro is loaded within this TTL time variable, then Confluence will get the information from the Confluence side cache instead of going to Jira for an updated response and would wait for the next scheduled full content re-index (which is a forced occurrence on an hourly interval).

A way you can bypass the caching delay mechanism for the Jira Issues Macro is to try using the manual refresh button within the macro, noting this is not the browser's refresh button but the one on the macro directly, this will attempt a fetch from Jira for renewed caching, but there could be load on Jira preventing the sync as well, or there could also be browser cache causing some conflicts here as well so a browser cache flush + macro manual refresh will give a bit more certainty. 

Alternatively, a more sure-fire way to force a request directly to Jira via the macro is removing the macro from your page, Publishing the page then re-adding the macro, and re-publishing, as any time a new macro is added to a page it will build out an In-flight content index operation to pull the newly added data over.

Hope this info helps explain the syncing process for you a bit more.

Regards,
Earl

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Confluence

Confluence: Where work and wellness meet

Feeling overwhelmed by the demands of work and life? With a 25% increase in the prevalence of anxiety and depression worldwide during the pandemic, for most of us, it’s a resounding yes . 🙋‍♀️ ...

974 views 15 27
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you