Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira Issue Macro not showing custom field value in Confluence anymore

Edited

Our confluence pages have a jira issue filters on them. This filter is set to show us four fields: Key, Summary, Status and Confluence Page. Confluence Page is a custom field we have created in Jira - free text. Previously these macros all worked correctly and all fields showed the correct values.

Recently (we are on Confluence Cloud and have not manually updated or changed anything on our system ourselves), the macros have stopped showing the Confluence Page value in our filters. I can see the value is still on the issue itself.

SampleJiraFilter-MissingCustomFieldValue.png

The xml export of the issue shows the custom field exists and has a value attached. I have tried removing the macro and replacing it. I have checked the custom field itself and it has a global context.

A different Custom Field (project extension) was added (for testing purposes) and I can see the value of that field in my macro. This custom field is not free text but rather a list selection. Looking at the xml for these two custom fields, the only difference between the two is that the Project Extension field has "key="10501" as part of the customfieldvalue itself. The Confluence Page field does not have a key.

OtherCustomField-showing.png

 

Does anyone know why the free text custom field is no longer showing in the macro and the list selection one is? Is there something else that I have missed that might explain why my Confluence Page field is no longer showing? Or has this broken as part of a Cloud system upgrade? If so, is it on the radar to be fixed? Whilst not a massive issue - it is something that needs to be fixed for us. I have looked at (issue) but that is closed and my problem is still happening. Maybe not fixed for cloud users?

10 answers

1 accepted

0 votes
Answer accepted

Also having (and ignoring) this issue since 2 months.

So apparently there was a fix for Confluence Server.

For Confluence Cloud when browsing then these bugs (and maybe more) seem to point to the same issue

* https://jira.atlassian.com/browse/CONFCLOUD-70306

* https://jira.atlassian.com/browse/CONFCLOUD-71131

* https://jira.atlassian.com/browse/CONFCLOUD-43561

hi, 

i'm experiencing this issue right now. anyone still having this issue?

 

cheers,

update

The custom field is showing now. I think it needs some time before the custom field can be used in Confluence after creation. it took me around 2 days.

Like # people like this

Still observed on 15-10-2021 on Jira/Confluence Cloud.
I can get JIRA standard field "Description" into Confluence using JQL filter macro, but not a "custom field" I've created more than 2 days ago...
Seems still like an "incoherency" (or bug... ) is present

Like Jessy Arrachart likes this

I am still observing the issue. No news about it from Atlassian? 

Hi, is there any fix available for this issue on Jira Cloud?

I'm experiencing this exact problem when introducing a new custom field within a Jira macro on Confluence?

Hey Team,

I am experiencing the same issue. It maybe take a few days to be updated?

This seems to have miraculously fixed itself as of Jan 12 2021. I assume maybe Chris found some fixes that were made that also sorted this issues. Cheers

In our case, We even can not show any results if we add our created custom fields inside Display Options.

Is there any update on this ?

Regards

Hello Again,

Yesterday It started to work correctly.

Best Regards

sampleConfJiraFilterBug.jpgA very similar problem here... A confluence page using a Jira filter containing custom fields all of a sudden (last week...?) does not display any values. In the sample picture, "external release notes" would normally show a text (which can be found on the Jira issue itself).

However, in the sample picture, "Topdesk Reference" is also a custom field, which still has values on the Confluence page

A theory to my reported problem here: seems related to custom fields with overlapping names from JIRA next-gen projects. This apparently makes the system mix things up. In our case, after finding and removing the next-gen fields, and waiting over night (sync delay jira - confluence?) the original pages in Confluence with Jira filter pages started to work again, and displaying the custom field content correctly.

Can I get more details on what next-gen fields are? And where or how this activity was done -   "finding and removing the next-gen fields"

 

Thanks

Like Mark Wheeler likes this

Same here, started within the past 24 hours.

Same issue here with custom label fields... 

I fear we are hitting this same issue with custom fields of the "Labels" type not being displayed in dynamic filter results 

Atlassian is there a ticket on this ?  

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Confluence

Confluence Mythbusters: Does Atlassian even use Confluence?

Hi, Confluence collaborators! As part of #Confluence-Collaboratory month, we’ve created a very special Mythsbusters segment, where we're dive into an interesting myth and uncover the truth behind i...

1,368 views 7 28
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you