Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Slow response after not using Atlassian server products for a while

Julius Zatroch March 4, 2020

When using Atlassian product in SMB companies, we are experiencing slow response / page load after not using it for 1 day and more. Typically at morning or Monday morning.  After few minutes ist working OK.  After many days of our testing (reverse proxy, SSD drives for software and database, increasing memory etc) it looks  everything is related to JAVA machine on background. Java is cleaning internal structures after not using it for a while. You will not see this behavior in bigger companies where many people are using Atlassian products every minute.

Are there some switches or parameters for JVM we can change at product startup to increase JVM internal cleaning time for maybe 30 hours? 

1 comment

Kurt Klinner
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 4, 2020

@Julius Zatroch 

 

Hi Julius

https://confluence.atlassian.com/enterprise/garbage-collection-gc-tuning-guide-461504616.html is a good place to start  to look for tunable options related to the JVM.

 

Having confluence and jira self hosted also in use (and not accessing it on a regular base i can not confirm that behavior). Is that specific to a certain product jira, confluence ... or a general problem. Which versions are you on?

 

Hope that helps

 

Cheers

Kurt

Comment

Log in or Sign up to comment
TAGS
AUG Leaders

Atlassian Community Events