Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to add users to user groups despite being an administrator

On Bitbucket, I am unable to add members to user groups despite being an administrator. 

The error message from the API is - "You cannot administer other userspersonal accounts"

Attached a screenshot.Screenshot 2019-05-14 at 10.42.09 AM.png

Everything was working earlier, but since a week I have started to face this error. Anyone here who can help?

3 answers

I'm seeing the same issue using BitBucket cloud admin interface:

"You cannot administer other userspersonal accounts."

0 votes
Ana Retamal Atlassian Team May 16, 2019

Hi Jitesh, welcome to the Community!

Before we can jump to help you, we'll need to know whether you're using Bitbucket Cloud or Server. Also, can you share with us how exactly are you trying to add these users? 

Let us know,

Ana

I am using Bitbucket Cloud.

Trying to add users from the User groups.
Like kousalya_94 likes this

@Ana Retamal Is there an answer to this? I still don't have a solution.

Ana Retamal Atlassian Team Sep 18, 2019

Hi,

From the error message that we see in the screenshot, seems like the user is trying to administer someone else's account instead of their own, which is not possible.

If you're certain that you're only doing this for your own account, please share with us the request you're sending, including the headers, so we can try to reproduce the issue.

Best regards,

I am trying to add/remove users from a user group. See the screenshot in the post below: https://community.atlassian.com/t5/Bitbucket-questions/Re-Re-Unable-to-add-users-to-user-groups-despite-being/qaq-p/1144041/comment-id/45103#M45103

I have admin access. So I expect that I would have authorization.

Ana Retamal Atlassian Team Sep 19, 2019

Hi @William Grand , thanks for linking the screenshot.

Having admin access to a user's repository doesn't give you admin privileges to his account. While you'll be able to perform admin tasks on the repository you've been granted access to, the control of the account remains solely to his owner. 

This is what you can do as a repository admin:

Admin - Allows users to do everything a repository owner can do: change repository settings, update user permissions, and delete the repository.

Other operations, such as changing the global settings of the account, or adding and removing users can only be performed by the owner. 

Hope this clarifies the situation, William.

Cheers!

Ana

Can you escalate this issue within Atlassian? The expected behavior of an Admin account is that the admin would be able to add or remove users. Otherwise, what is the point of being an admin?

Like # people like this

Hi Ana, At our company, our CTO is the admin and every time a new person joins our team, we need to immediately provide him access to our bitbucket repositories.

In situations when our CTO is unavailable or on leave, the work gets delayed and there is a substantial dependency on him to add users. 

I am sorry to say but the solution that you have designed is extremely poor and not at all user-friendly. There should be some way for the account owner to delegate access to add users to other people within the team.

Ana Retamal Atlassian Team Sep 19, 2019

Hi @jiteshdugar ,

Seems like you're using the wrong type of account. In your case you should be using a Team account. A Team account can have several account administrators so when one of them is missing, the rest of the admins can continue doing the administrative tasks and the team doesn't suffer any delay. 

You can learn more at Teams and Create and administer your team.

Let us know if you have any questions regarding this type of account.

Regards,

Ana

Ana Retamal Atlassian Team Sep 19, 2019

Hi @William Grand ,

I agree that the expected behavior of an account admin is that they'd be able to add and remove users, but you're not an account admin, just a repo admin.

As I previously mentioned, the permissions that person granted toyou give you only admin privileges to that specific repository, but not to his account. As a Personal account, the only account admin is the owner. The owner can decide to let other people access his repositories and there are 3 levels of permissions: read, write, and admin. You can find more about them at Grant repository access

If you'd like to have an account where several people can be administrators and have power to add/remove users, then you're looking at a Team account. You can read more about this type of account at Teams Frequently Asked Questions.

I have confirmed that the account you have access to is just a Personal account and not a Team. Would it be a Team account you'd be able to be an account admin and add/remove users. 

Hope this explains,

Ana

@Ana Retamal  That's all great in theory, except there isn't even such a thing as a team anymore in Bitbucket. The notion of a team seems to have changed to that of a workspace. Even your documentation that reads "Create and administer your team" points to https://confluence.atlassian.com/bitbucket/create-and-administer-your-workspace-966686578.html.

And with a workspace, only the owner it seems can do any administration for the workspace itself. Other users set as Admin can only administer individual repositories. This is beyond flawed as far as the behaviour one might expect by setting someone up as a Workspace Admin.

Even though I'm a workspace Admin, I have to bother the workspace Owner to perform admin tasks. Does the Atlassian team realise how ridiculous this is?

A related issue: https://community.atlassian.com/t5/Bitbucket-questions/Difference-between-5-User-Team-and-Personal-Account-during-Sign

Like # people like this
cwilliams I'm New Here Aug 03, 2020

Totally agree with you, this is A MAJOR issue. I've got workspace admin rights and while I can add users in a round about convoluted way. Select User Groups, Select a group, add member. I receive the error we've all been seeing. But if I select User Groups then add member it works. Now to remove a member I go through yet ANOTHER convoluted method. You'd think opening the group in question would allow me to remove a member but no, it doesn't. Yet if I go to Users on plan I can remove a member there.

Couple that with I can't add an OAuth consumer so I am unable to hook this up to TeamCity and I'm up to my wits end.

I have the same problem.. Is this issue fixed? Is there any other method to remove a user member from Bitbucket? @Ashvin Narayanan or @cwilliams  have you received / found any solutions? 

I, too, am experiencing the same issue, however I am attempting to create a repository over the Bitbucket API.

I receive a 403 Forbidden response with the following content when trying to create a new repository in a workspace that I am set as an admin for:

{"type": "error", "error": {"message": "You cannot administer personal accounts of other users."}} 

I am running into the same issue. It resolved itself after resending invites and accepting. 

 

 

Did anyone find an answer to this? I get the same error on the web on Bitbucket Cloud:

 

Screen Shot 2019-07-31 at 12.58.11 PM.png

here got same error on Fork.app

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

1,826 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you