codedeploy fails running bash script

Hi guys,

I use Amazon CodeDeploy for my Bamboo build process. Out of the blue, CodeDeploy is failing when it runs my 'AfterInstall' bash scripts. What's odd is that this was working fine, and then suddenly it stopped working. Also, if I run CodeDeploy from within the AWS console, it works fine. The issue is only when Bamboo triggers CodeDeploy.

Again, the issue started out of the blue when the process was working and no changes were made.

CodeDeploy is finding and running the Bash file, but it throws this error and fails: [stderr]/usr/bin/env: bash : No such file or directory

Again, this works fine if I run it from CodeDeploy directly. Any idea of what could be going on or know of any changes in how Bamboo calls CodeDeploy?

 

Thanks!

 

-Jeff

1 answer

1 accepted

This widget could not be displayed.

FYI, this was caused by my elastic instance changing from a Linux image to a Windows image. Because of this, the file changed from a LF to a CRLF and added carriage returns to my bash files. 

I fixed this 2 differnet ways:

  1. I disabled all Windows options in my 'Image Configurations'.

  2. In .gitattributes i added the line 

    *.sh eol=lf

 

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published 6 hours ago in Marketplace Apps

The 7 hacks of highly successful automation

...there's anything I've learnt from working, it's that people are lazy! No offense to anyone reading this, but it's true and we can all admit it. The easier you make something for someone, the more...

38 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you