Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,724
Community Members
 
Community Events
176
Community Groups

Automation/Integration with Teams failed (400 - Webhook Bad Request - null or empty eventType)

Hi,

I've tried to run an automation integrating with Teams. I've created and used a webhook: https://myname.webhook.office.com/webhookb2/... (created on Teams channel level).

But my automation fails with an error:

Error communicating with the API
400 - Webhook Bad Request - null or empty eventType
What's the issue here? Is it on Jira or Teams side?

1 answer

0 votes
Eric Atlassian Team May 24, 2022

Hi @Hubert Bartkowiak 

 

Based on your description sounds like there could be a problem with the request payload you're sending from Jira. Sounds like the payload needs eventType but it's not specified?

 

 

Cheers,

Eric

I don't use field named like that in automation. 
I worry that might be some permission on teams/office level?

What I check or trouble-shoot here?

Eric Atlassian Team May 26, 2022

Hi @Hubert Bartkowiak 

 

Apology for my previous response. I think I misunderstood your original question.

 

Could you please take a look at this community question: https://community.atlassian.com/t5/Bitbucket-questions/Jira-Automation-Microsoft-Teams-Message-with-Error-400/qaq-p/1341087 ? I think it's the same problem as yours, perhaps you could try the suggested solution.

 

 

Eric

Thank you. Strange I couldn't search for it... I cannot see this webhook, but I will continue topic there. 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events