Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

Recognition

  • Give kudos
  • My kudos

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Have problems with macros in Confluence after migration from Cloud to Server. Edited

Hi!

We have just moved our Cloud instance of Confluence into Self-hosted one and faced with the problem, that macro, that shows children pages doesn't work with the pages, that was migrated. It looks like this:Screenshot_2020-10-07 Главная - Atlassian -.png

We concider, that it's a problem with links, cause it can't find the pages. We already made connection between Jira and Confluence, changed everywhere links to new instances, but we don't know how to decide this problem only in Confluence. We cleared cache, made re-index of content, it didn't work. What should we do with it?

1 answer

0 votes
Ivan Lima Community Leader Oct 07, 2020

Hi @korotichas,

You mentioned that you migrated from Cloud to Self-hosted. So, I have a few questions that might help us better understand your challenges and, perhaps, these questions can help you with that too.

  • Which version of Confluence Server, or DC, did you migrate to? It's recommended migrating it to the latest versions.
  • Since you described that the macro couldn't find the pages, have you had a chance to check if the pages are now orphaned pages? I don't see a specific reason why it could happen during the migration process, but it doesn't hurt to double-check that too.
  • Also, I suppose you have done it by now, but what happens if you try adding the same macro to a new page?
  • Another check that I would do is to compare the storage format of the page you're facing this issue against another one, with the same macro, so that you can check whether the macro ids are matching.
  • Well, I would check the logs to try to find more details about the errors. This is actually one of my starting points to check stuff.

Cheers,
IL.

Answer to your questions:

We migrated to version 7.7.3.

All of pages have children pages, i checked.

I tried using this macro on another page, it still doesn't work with pages, that hsd been migrated from Cloud instance. But it works great with pages, that i added into new instance after migration. I checked source code of page, but still have no ideas why it doesn't work. Source code looks the same in macros.

Even though you mentioned that it works for new pages, another possible reason that I can think of is that it could be either a user macro that was not brought over or a specific module disabled on the managed apps settings page. Typically, messages similar to the one you shared relate to that.

For example, in the screenshot below, the first one is the "Children Display" macro that I disabled the respective module. The second, a user macro that I've created and deleted so that we can see the missing reference. 

Screen Shot 2020-10-07 at 1.12.57 PM.png

These are the initial checks that I can think of at this point. I would be interested in hearing what others have experienced around this.

I hope that this can shed some extra light on that but, in the meantime, I would suggest raising a ticket with Atlassian support so that they can check your logs and likely find the actual cause of that.

IL.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you