Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,301,108
Community Members
 
Community Events
165
Community Groups

New user not receiving invitation email

There's new user joined company and I invited him as what I did before. However, this time the new user hasn't received anything. I tried to resend in user management tab for several times, and he carefully checked all the mail boxes, there's no invitation mail.

It worked well days ago. And I don't think it's due to company mail server as we're using same company mail server and others can receive invitation mail before.

Any possible way to figure out what goes wrong?

10 answers

2 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

2 votes
Answer accepted

We have the same problem. How could this problem lasted for years not corrected? 

Shannon S Atlassian Team Aug 08, 2018

Yuan,

The issue usually is that the user was signed up just as or right before their email was created, so the email host sends back a "550 user not found" error to us.

This then puts the email on a block list since the server essentially told us that the user doesn't exist. All it takes is for someone from Atlassian to remove that block, and then you can send a password reset email again.

We have a bug below to correct the issue. I would recommend commenting on the bug with your experience, and voting in order to show the number of users who have been affected by the issue.

Regards,

Shannon

Like # people like this
Nicholas M Atlassian Team Oct 17, 2018

This bug has now been resolved. If a user has been blocked because of incorrect setup for example. you can now use the resend button in the users page to unblock the email and resend.

If its still not right i.e mailbox full, mail server down etc it will be re blocked again. Obviously fix the setup first, but now you can use the resend to quickly test you have fixed the local problems. 

@Nicholas M @[deleted]

I still have this issue. Confirmed all of the above.  Resend option doesnt work either.  Is there any suggested trouble shooting steps? This shouldnt be so cumbersome. 

Nicholas M Atlassian Team Nov 20, 2018

@Jonathan_SalaveriaIf you are confident you have no issues with your local mailbox or incoming mail-servers and re-send does not work (keeps getting re-blocked) it could be something in your mail systems that's rejecting the message itself (not the recipient) i.e the content of the email: rejecting that particular message if it thinks it looks like spam.

You can raise a support request and they can investigate in more detail. There is one block list where we don't remove the email if it fits in the above example case. It's a very small % and its better to handle manually if that is the case.

1 vote
Answer accepted

After raising a ticket to Atlassian support, an Atlassian support engineer checked on their side and found the email was blocked at their side.

Then they just unblocked it and everything went well.

cool, we get the problem too.

Hi Richard, how did you raise this ticket to the Atlassian support team?

Shannon S Atlassian Team Aug 08, 2018

Hi Jennifer,

I just saw your reply here while responding to Yuan.

You can raise your request from our contact form, and a member of the Cloud team will be able to remove the block for you.

Regards,

Shannon

I am still getting this problem. The funny thing is if I try to create a support issue myself I do not get the email notifications either. 

Hello Everyone,

We want to ensure you have the most up-to-date information about Bitbucket invitation issues and how to get support. With this said, we've published an article relating to this topic and how to best get support and quickly be unblocked.

Please see How to get support for Bitbucket Cloud invitation and notification issues.

In the above article, you will find the best ways to get unblocked along with the context of the problem, causes, and steps to know to avoid in the future.

 

Community Product Lead,
Stephen Sifers

I got the same issue and was able to resolve it by creating a support ticket. Below is the response.

------------------------------------------------------------------------------------------

We received a rejection message from the recipient's email server. Once our email provider received the message, the email address was placed in a blocklist preventing any additional email from being sent to the address.

I've gone ahead and removed the email address from the list. Can you try sending the invitation again? It should go through this time.

Currently, there is no indication when an invitation email is blocked/rejected. We are aware of this issue, and we have an issue tracker open with our development team. You can access it here

I've linked this ticket to the issue tracker. Please consider adding yourself as a watcher as it is the best way to stay updated.

-------------------------------------------------------------------------------------------

I'm having this problem, too. I've invited 3 new users over the past few days and none have gotten their email. Two are from outside our company's domain and the most recent from within. I've resent to all 3 multiple times, but it never is received.

Hi, I had same issue. Users didn't get invitation emails or not possible to reset their passwords.  No email reached their inboxes.
Atlassian Support checked that they were no blocked.

I have invented simple workaround finally.

I asked user to install Jira cloud app on mobile and have password reset from the app. In result user immediately got email in his inbox and could access Jira.

I am not receiving an email notification for my initial registration.  

I also have problems with invited user who don't receive an inventation message.

When I click Add customers in a Servicedesk the user doesn't receive an EMail.

Shannon S Atlassian Team Oct 09, 2018

Alfred,

If this is for Cloud then you'll need to raise a support ticket so we can have a look at the email logs and see if something is being blocked.

Regards,

Shannon

Hi Shannon,

 

I had this problem last week.

Today I deleted some of the users I added last week and added them again.

Now they receive an inventation message.

Seems to be solved.

 

Regards,

Alfred

Like Nayan Shrimal likes this

We are having the same issues; have been trying to get a team member signed up for 3 days and email never arrives.

Hi Richard

Obvious question, but worth checking : are you sure you have the person's e-mail correct? I always copy the e-mail address from Outlook to ensure no typos

Surely I was doing same thing as you did... copy the email address from outlook.

But it's several day passed, and I tried to resend many times... he just received nothing.

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

TAGS
Community showcase
Published in Atlassian Access

Atlassian Access Demo Q&A Recap

Hi Community! Thank you to all who joined our ongoing monthly Atlassian Access demo! We have an engaging group of attendees who asked many great questions. I’ll share a recap of frequently ask...

1,173 views 4 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you