Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,362,839
Community Members
 
Community Events
168
Community Groups

How to correct Atlassian SDK Build Error.

 

When I run the command "atlas-create-jira-plugin", I get the error below.

I am using Atlassian SDK version 8.0.16 and Java SE Development Kit 8 update 241 (64-bit). 

 

image.png

1 answer

0 votes

@Brett Bell 

 

Hi Brett

 

the issue is related to the truststore of your JDK.

One possible cause could be that you run behind a proxy and need add the certs for the proxy to your truststore, see https://techgrafitti.wordpress.com/2011/03/02/maven-unable-to-find-valid-certification-path-to-requested-target-issue/

 

Cheers

Kurt

Unfortunately that article is not detailed enough for my simple mind to follow.  For the step "Go to the mirror site in you web browser and save the certificate for the site at a location", I used http://www.myhost.com/maven/jdk14 (don't know if that is correct or not but that is what is in the settings.xml file.  I am using jdk1.8.0_241 so what mirror site should I use?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events