The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

Opsgenie dont response to Elastalert request

Mykola Voroniuk
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 24, 2022

 This problem repeats often when sending alerts from elastalert to opsgenie api.
Please help me to resolve it

INFO:elastalert:Error response from https://api.opsgenie.com/v2/alerts 
 API Response: <Response [413]>
ERROR:elastalert:Error while running alert opsgenie: Error sending alert: 413 Client Error: Payload Too Large for url: https://api.opsgenie.com/v2/alerts
INFO:elastalert:Disabled rules are: []

 

1 answer

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

0 votes
Darryl Lee
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
March 28, 2022

Hi @Mykola Voroniuk ,

This is Darryl. I am here to help. 

Understand that you would like to create Opsgenie alerts via API from your Elasalert side.

From the error message, it looks like the payload content is too large or does not match the acceptable format that Opsgenie Alert API accepts.

Please help confirm if your Elasalert can generate the JSON payload in the format described on our Create Alert API document.

If the payload format is valid but this issue still occurs, please consider reaching out to Opsgenie Support via this link and my colleague will help you from there.

Thanks.

Kind regards,
Darryl Lee
Support Engineer, Atlassian

TAGS
AUG Leaders

Atlassian Community Events