"Create service request" automation action broken?

Adam
Contributor
June 12, 2023

I'm trying to configure an automation in a JSM project to create another request in the same project. I first tried to use the Create Issue action but found one cannot set the "Request type" field using the Create Issue action. I then tried to use the "Create service request" action but nothing ever loads (spinning animation).

I've tried, changing the Actor to a site admin and doing the automation as a global automation but I never get anything to show up on the screen after waiting a few minutes.

When looking in the browser console, the called endpoint returns no results. The URL has been sanitized ("siteName")

If this is really broken I guess I could setup a workaround, using the Create Issue action and some temp ~flag, where after the item is created it automatically edits the issue's Request Type.

{
"size": 0,
"start": 0,
"limit": 50,
"isLastPage": true,
"_links": {
"self": "https://siteName.atlassian.net/rest/servicedeskapi/servicedesk/15/requesttype?searchQuery=",
"base": "https://siteName.atlassian.net",
"context": ""
},
"values": []
}

 

Automation loading.pngautomation response.png

3 answers

1 accepted

1 vote
Answer accepted
Adam
Contributor
June 15, 2023

After submitting a support ticket, Atlassian confirmed it was a known issue and that a workaround exist.

Cause

When the create service request action loads, it makes two requests to Jira:

  1. Get all the service management projects (taking into account user permission etc)
    Get all the request types for the first service management project returned in the previous step
  2. If the second request returns an empty collection (because the service management project has not been configured) then the action will not load. Users will see a spinner that goes on forever.

Therefore, when the first service management project doesn't have any Request types, then automation exhibits this behavior. (It could be a DEMO project or a TEST project not in use)

Solution

  1. Navigate to the first service management project in the list of projects (https://<instance_name>.atlassian.net/jira/projects)
  2. Filter Jira Service Management projects(if you have other types of projects as well)
  3. Navigate to the Request Types of the first project in the list returned in step 2(Project Settings → Request Types)
  4. Add a dummy Request Type in the project. If you prefer, do not add it to any portal groups so that it stays hidden from the project portal.
  5. Navigate to the automation page and try again
0 votes
Adam
Contributor
June 14, 2023

Hi @Fernando Eugênio da Silva , thanks for your suggestion. It's certainly a more streamlined workaround.

We'll see if someone from Atlassian confirms if there's a bug with the "Crease service request" action. I think I'll create a support ticket as well.

0 votes
Fernando Eugênio da Silva
Community Leader
Community Leader
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June 13, 2023

@Adam 

You can do this with Jira automations, you just need to use an additional resource to get what you want. Your automation rule needs to be like this:

  • Trigger > Your trigger
  • Action > Create Issue
    • Select the project
    • Select the Issue Type
    • Select any other field you want to fill automatically by the rule
  • Add a Branch (this is what you need)
    • In the branch select the Option Most recently created issue
    • Inside the branch add an Edit Request Type action
    • Select the Request Type you want to use.

Note that the Request Type needs to be mapped to the Issue Type you are defining, otherwise your rule will not succeed.

See the example:

Screenshot_118.png

Hope this helps :)

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