The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to access the Jira URL after added the SSL Configuration

satheesh
April 14, 2021

Hi Team,

When i added the SSL certificate in my Jira service desk, i'm unable to access the jira.

I have followed the below steps.

1. I have created the Keystore file and I kept in Installation-directory/conf.
2. and i have modified the server.xml file and i kept the below code.

<Connector port="8099" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;" protocol="HTTP/1.1" SSLEnabled="true"
maxThreads="150" scheme="https" secure="true"
keystoreFile="/data/jira_ITHD/conf/keystore" keystorePass="moijira1"
clientAuth="false" sslProtocol="TLS" sslVerifyClient="optional"
sslEnabledProtocols="TLSv1.2,TLSv1.1,SSLv2Hello"/>

3. at the same time I have modified the web.xml file and i kept the below code.

<security-constraint>
<web-resource-collection>
<web-resource-name>securedapp</web-resource-name>
<url-pattern>/*</url-pattern>
</web-resource-collection>
<user-data-constraint>
<transport-guarantee>CONFIDENTIAL</transport-guarantee>
</user-data-constraint>
</security-constraint>
4. after that I have restarted the Jira server and tomcat started but i'm unable to access the Jira URL.

Note: I'm unable to take the SEN and zip file because of Jira not up and running, can you please help me out, Thanks.

Regards,
Satheesh K

0 answers

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

TAGS
AUG Leaders

Atlassian Community Events