no data connection. unable to sync board. unable to sign in. problem Edited

Hi, I've got a problem on Android that I cannot figure out.    I've been using Trello enthusiastically without any trouble on my android phone for a couple of years now.  In fact, it is the single most important app that I use on my phone!  My phone is a Samsung GT-I9195, android version 4.4.2

  The problem started a few days ago.  I couldn't sync my boards.  THe app reported, "no data connection.  cannot sync board"    But my wifi connection was good, and other apps that use the internet, like my mail or skype were not having problems.  I tried a bunch of things, including finally removing the Trello app from the phone and re-installing it.  Upon relaunching the newly installed app, I had to sign in.  You guessed it: I was unable to sign in.  The app reported, "Cannot log you in.  Looks like Trello is having some issues.  Please try again later."

THen I thought, uh oh, the newest version of Trello app does not work on my phone!  But fortunately, I have an older version on another phone.  I last used that version of Trello (successfully) in March. (The other phone is an LG G3)  I fired it up and looked at my boards.  THe same error again: "no data connection.  cannot sync board" - even though the LG G3 was clearly connected to internet via WiFi.

Please help!  My life is a shambles without trello!

10 answers

This widget could not be displayed.

I started having the same problem with the Android app a little over a week ago. I haven't "solved" it but I have a temporary work around. I quit using the app completely and logged on to the Trello mobile website (this doesn't require installing the app). This works great but if you lose your internet connection, you don't have access to your data.  Not perfect, but at least you can use Trello when you're connected to the internet.

Amy Jonak I'm New Here May 14, 2018

Thanks very much. Saved the day. I'm just shocked and disappointed they dumped us like this -- NO WARNING that I can find! Geeze, I've plugged Trello so much over the years. No more. Already lost 2 other project/organizer sites. Lesson learned.

This widget could not be displayed.
Entell I'm New Here May 13, 2018

Same issue. Started on last Tuesday for me. Galaxy S4 mini here. I will not not buy another phone for the app. I cannot find a smaller phone that has 4G than the S4 mini. Old Apple phones are close but I would rather use a string and a can due to the inflexibility of Apple phones. 

Check your android version.  4.4 is ancient, I'm running 7 and have the same issue.

This widget could not be displayed.

THank you all for the replies!  I can't believe that Trello has simply dropped our phones without further ado!  I wonder how many more people this is affecting?  (For us) this is a very serious problem, a serious breach of trust.

Same issue here on a lg stylo 3. If I make an update online, my app will sync and show it . But if I try to update within the app it either wont sync or takes 24 hours. 

 

I'm a heavy user and really need this to work.  I'm only on front of a computer about half the time and rely on trello app. 

In my original reply above I'm not sure I explained my work around clearly. I am unable to use the Trello app on my phone but ....... I AM  using Trello on my phone by going directly to the Trello website without the app.  One method to get there is to google "trello.com" and click on the link provided. You will get live access to all of your data in somewhat different, but very usable format. As a bonus, you'll get a lot of functions not available in the app.  I was on Trello using my phone today for an hour, no app required. I hope this helps. 

..probably the only "solution" or buy a new phone...

PJC52: I understand the workaround, but its quite inconvenient in my case as I am offline many times due to being rural, and need to see my trello content in an offline state

This widget could not be displayed.

Hi Boris,

Thanks for reaching out about this and I'm sorry for any inconvenience this may have caused.

We’ve recently made some changes to our system where we are no longer supporting the Android version 4.4 (Kit Kat). 

Unfortunately, we messed up, and those changes no longer allow us to support the KitKat version of Trello. While it was an old unsupported version, we didn’t actually mean to break it in such an unceremonious way and we apologize. We tried to figure out a way to restore it, but we couldn’t do that without a decent amount of work and because it’s so old we’ve decided to just end support for that version. We are really sorry for the frustration this has caused. 

Please let us know if you have any other questions or concerns, and we’d be happy to help.

I'm running Android version 7 and having the same problem

Bob Shuka I'm New Here May 14, 2018

This is a MAJOR breach of customer trust. 

"we couldn’t do that without a decent amount of work"

I suggest you reconsider measuring the value of customer trust against the cost of a "decent amount of work." When Atlassian acquired Trello I feared the product would go downhill and, in my opinion, this validates that fear. Trello WAS part of my daily workflow which I now have to completely reconfigure.

Bob:  I don't like this any better than you do, but how is it a breach of customer trust?  They're aren't displaying wrong data, they just aren't updating.  10 years ago this was normal in the client/server world and it wasn't a customer trust issue then.  I'm not saying its good, but lets not over escalate issues.

Secondly, sometimes to move a product forward, you do have to rip out old pieces to make it work properly under current standards.  This is a difficult decision for developers because they generally want to support as many devices as they can, since this drives adoption of the product.  But sometimes, they do have to drop support for old devices to make the new ones work better.  The "significant work" likely has to do with presenting different wireframes and features to different devices, and the maintenance around that is astronomical.

Thirdly, I don't think the story is written on this.  I'm having issues, and I'm on Android v. 7, not 4.4.  There's more to this story.  I replied to Trello on my ticket and hopefully they will reply to me.

THanks for your reply, Marta.  I'll have to figure something out on my end, I guess.  I'd like to get logged in, at least, on my old phone, and get the old non-functional trello app to run again (the one I removed).  It was not allowing updating from the phone, but at least I could look at my data. 

I understand the workaround that another person suggested - using a browser to access my Trello account - but that cannot work for me in many situations, as I do not have a data plan on the phone.

I'm researching possible OS updates.  Do the changes at Trello affect Android v.5 Lollipop?

THanks for any advice!

That is unfair!! 

What's happen with the all users that we still use kitkat?

This widget could not be displayed.
Teemu I'm New Here May 15, 2018

Same problem with LG G2, Android version 4.4.2.

I found out you can avoid losing your data! If you have made edits that have not synced, open Trello, open Settings, open "Sync queue", select Export. You can then add it to a cloud drive for example, or use any other way of sharing it with yourself. This file will be a .json, so you can use this converter (as suggested by Trello help pages) to turn it into a CSV file that you can open in Excel for example, and you will get a list of changes in a readable format.

For more, see: https://help.trello.com/article/1079-troubleshooting-for-the-android-app

"If you're not able to get on a network, or if the changes don't send for some reason, you can export a list of the changes so that you can redo them later if they're lost. To do this, open the app and go to the Account tab. From there, open the Sync Queue. Tap on the share button to send yourself a text description of the changes."

I have been using Trello for years almost daily, and I must say this lack of concern for users was unexpected. Would it have been difficult to send out an email for everyone informing about the change and include instructions for the problems this may cause? (I think it is not too late yet!)

This widget could not be displayed.

You cannot better describe my problem... Did you solve it finally ?

I guess this is a compatibility issue like you mentionned, however Trello should come with a solution for this: I won't buy a new phone just because of Trello...

This widget could not be displayed.

Trello Support suggested I either try an older version of Trello or update my phone software. I have an older model Galaxy S4 which can only be updated to android 4.4 or 4.5 and no further. Seems like the new version and even the old versions of the Trello app need at least android 5.0. Which is odd because because I have been using Trello successfully for at least 2 years until about 1 week ago when the app started being problematic. So basically no fix for the app to work. Using Trello through chrome or another web browser is a work around but in my opinion less user friendly and more clunky. It doesn't seem to allow me to drag cards or lists around like the app does. Very dissappointing and frustrating since it worked fine for so long. And I really don't understand why the old app versions don't work.

This widget could not be displayed.

...I have exacltly the same problem...and no answer from trello helpdesk... Samsung S 4 mini

This widget could not be displayed.

It's the same issue here: looks like support for old android has been dropped :(

...well, how often we are going to be forced to buy new phone to use trello :-)?

Check your version... Mine was 7.

This widget could not be displayed.

My phone, which was running Android version 7, recently received a security update and the app has been working fine for me since then.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published Jun 20, 2018 in Trello

Get inspired with Trello & earn free Gold

A blank Trello board can be both a beautiful and intimidating thing. How many lists should I have? Is creating 10 labels overkill? How can I best track my progress? Is there a way...

17,118 views 0 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you