It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why wont Trello show up on Google Chrome?

I just restarted my computer this morning and for some reason Trello will not show in my Google Chrome browser, although it continues to work in Firefox. It appears to load when I refresh the link but I just get a blank screen.
Thanks for any help that anyone can give.
MW

2 answers

1 accepted

1 vote
Answer accepted

Does this also happen in an incognito session in Chrome? Might be a Chrome extension interfering with Trello or something.

Hi Alex,

Thanks for your response but I do not know what an incognito session is. Anyway, I figured it out (for others who might have this same problem) I went to the drop down menu on Chrome and opened Preferences and then went to Settings. In there was a box that said that something (I can't remember what it was called ) was preventing Trello from opening. Anyway, I reset that to "open as normal" and then refreshed my Trello pages and wala! 1 point for those of us who struggle with tech. 

But really thanks for reaching out and trying to be of assistance. it is appreciated.

MW

I and several members of my team have started to experience this same issue. We have been on the business platform as a department for more than eight months now.  These glitches started happening after the beginning of the year. Only one power-up has been added since then, but this issue started well before it was added.

More often than not when trying to access a Trello board in through a browser it does one of two things:

1. Takes forever for the board to load and when you think it is finally going to load an error message appears asking if I want to Wait or Exit as the page is unresponsive.

2. The board finally loads but it takes a good one to two minutes.  While it is loading all the cards and user image circles turn into solid gray shapes. Once loaded and I try to add a comment to a card, what I have typed is on a two-three second lag before it shows up in the actual comment box. 

I have read several posts here and I have tried the following:

-  Cleared cache in both public and incognito environments.

-  Tried in different browsers

-  Tried opening the same board in an incognito window and private windows in the other browsers. 

 

Please help my team of 20 is starting to get very agitated and it is starting to hinder productivity. 

If all 20 team members are experiencing these same issues in the same browsers and pretty consistently, it sounds like there might be something wrong with the specific board. Do all of your boards act like this, or just one? Are you all on the same connection, all using the same VPN, or something like that?

In this case, I'd contact Trello support directly. They might be able to provide some more technical insight.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Trello

Develop a new Habit during Lockdown

If you had to thrive a new habit during a lockdown, what would it be? Trello

1,550 views 13 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you