Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to login using Google account on Trello for Mac

When I click Google account icon on Trello for Mac, nothing happens and if I wait longer, the whole app window will turn blank and nothing else.

1 answer

0 votes
Mike Atlassian Team Sep 26, 2017

Hi there,

Are you signing into an existing account or creating a new account? Are you able to sign in at as expected, just not via the app?


We just released version 2.9.6 of the app, so let's start by making sure you're fully updated to the newest version. If you're still having this problem after that, I would encourage you to reach out with some more computer and OS version details to, and we'll be glad to look into what's going on!

I'm using Trello (for Mac) version 2.9.7. From what I can tell, this is the latest Mac. 


I use Trello at work, and I'm unable to log into the Mac app using Google Auth. I can log-in just fine with my web browser. 


This is a bug perhaps? 


Edit: I was able to workaround this problemn by setting a password, and then using my email and password to login. It's a pain nevertheless. 


I am having the same problem. I can login fine on the web. cant login to the mac app.

As you see in the screenshot, I am using 2.11.7 version of Trello. My Mac pro is the latest one too. Just frustrating. Hope you guys fix this problem. Seems like it has been there for 3 years !!!


Screen Shot 2020-08-26 at 14.44.13.png


Screen Shot 2020-08-26 at 14.40.54.png

Like Boris Jung likes this

Same Problem here...

Same here!

I get something like "can't log you in, this browser or app is possible not secure. Please use a different browser". (translating freely here).

I get it after providing my gmail adres, where I would normally get a password prompt.

Click "can't access account" then choose the option to send a recovery link to your email. This will allow you to attach a password to you Atlassian account if you never had one before because you only ever used your google account. Hope this helps!

The mac app login problem was solved for me. I reported the problem here 5 months ago... was using the web since then.... tried to login today in the mac trello app.... it logged me in. below is the version of my mac and trello app version.

I hope this helps. 

Mac OS Big Sur 11.1



Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Trello

Taco Tuesday: Your favorite Trello blog takeaway

Hello friends! From the community that brought you Welcome Wednesday, Throwback Thursday and Friday Fun, welcome to Taco Tuesday, a weekly discussion about all things Trello. The best part? One Tac...

325 views 13 12
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you