Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,434
Community Members
 
Community Events
168
Community Groups

Unable to Access Trello Account

I'm not able to access my Trello boards today. After going through the usual two-step login process, I was bounced to the Trello home page. The page has a "Go to your boards" button in the upper right-hand corner. When I click that button, it simply does a refresh of the home page without taking me to my account page.

I'm accessing Trello using the same brower I always use - Firefox (current v 103.0.2 (64-bit)).

Is anyone else experiencing the same problem?

Does anyone know the cause?

Does anyone have a solution?

 

Trello.png

1 answer

UPDATE: Problem solved!

I was able to resolve by clearing my browser cache and then attempting to login afterward.

Thanks for the tip Avi! Same thing worked for me.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events