Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,294,705
Community Members
 
Community Events
165
Community Groups

Uh oh! There was an error adding Trello to Slack.

Whenever I attempt to add the Trello app to slack I end up at the following URL

https://trello.com/integrations/add-to-slack-error

Uh oh! There was an error adding Trello to Slack.

 

If I go to the members section of Trello and try to add Slack integration I get the same result no details anywhere.

4 answers

0 votes
Koos I'm New Here Apr 27, 2022

I was experiencing the same problem and found that I couldn't connect the integration in Firefox. Not even with Enhanced Tracking Protection and uBlock Origin disabled. Using Chrome, the instructions above worked.

0 votes
Garrett Atlassian Team Aug 31, 2021

Hi everyone!

We've had a few users report that the issue only occurred in a specific browser and switching to another helped them authorize successfully. Specifically, Brave's shield feature seems to be breaking the authorization, although the issue could be a similar ad-blocker feature in other browsers.

If you're still experiencing trouble, I'd suggest giving these troubleshooting steps a try:

First, check if your browser is fully up to date: What browsers and mobile platforms does Trello support?

After confirming you're on the latest version, try authorizing the app following each of the steps below:

  • Disable all extensions and customizations in your current browser
  • Try using Incognito or Private browsing mode
  • Try using a different browser on the same computer
  • Try using a different computer

When trying to authorize the app, please use the steps Lara shared previously:

  1. In Slack, type in the command /trello unlink and /trello reset.
  2. Go to your Workspace page in Trello
  3. Scroll down to the Slack linking section
  4. Select Add to Slack
  5. Follow the authorization steps

If the issue persists, send us a message over at https://trello.com/contact and we'll be happy to take a closer look with you. Just be sure to include what browser and OS version you attempted this with.

Hello,

I have the same issue, and it didn't resolve after following your suggestions.

I'm using Firefox - could this be the issue?

Yad

0 votes
Lara Atlassian Team Aug 08, 2021

Hi Kenneth,

Thanks for reaching out!

Let's try starting with a clean slate to see if that helps get Slack working again. Would you mind trying the following steps for me please?

  1. Go to the board where this Power-Up is enabled.
  2. Open the Board Menu and select the Slack Power-Up.
  3. Select Remove personal settings and Disable the Power-Up.
  4. Go to https://trello.com/my/account
  5. Under the Applications section, select Revoke under any entries for Slack (if any are found).
  6. In Slack, type in the command /trello unlink and /trello reset and reauthorize your account.

After that, go ahead and reenable the Slack Power-Up and follow the authorization flow. Could you let me know how that goes please?

I'll keep an eye out for your reply,

Lara
The Trello Team

i have same trouble with slack power-up.

and i have done all of that you recommended.

but nothing's change. 

still every time i add slack team in trello, it ends up with 

https://trello.com/integrations/add-to-slack-error

i need profer help.

Lara Atlassian Team Aug 22, 2021

Hi there,

Could you please go to your Workspace settings page and unlink the Slack team?

Image 2021-08-23 at 1.28.49 pm.png

If there is no Slack team linked, please click Add to Slack:

Image 2021-08-23 at 1.30.57 pm.png

If the issue persists, please reach out at https://trello.com/contact and we can take a closer look.

All the best,

Lara
The Trello Team

Hi Lara,

I get the same issue as the people above. I followed your latest instructions but still get the same error:

https://trello.com/integrations/add-to-slack-error?error=State-Check-Failed

Screen Shot 2021-08-24 at 8.38.06 PM.png

This error also showed when unlinking the authorized Slack workspace and then trying to link again.

Thanks,

Lara Atlassian Team Aug 24, 2021

Hi Vincent,

Are you able to link the Slack team via your Workspace settings page?

Image 2021-08-24 at 4.40.15 pm.png 

If not, please reach out via https://trello.com/contact so we can take a closer look. Thanks!

Lara
The Trello Team

Hi Lara,

Unfortunately, I get the same error page and message as above when I click on the 'Add to Slack' button:

Screen Shot 2021-08-25 at 2.56.23 PM.png

I guess I'll trying contacting your support through the link you provided above then.

Vincent

Hmmm actually the link you provided https://trello.com/contact seems to be broken too...

OK I found the culprit in my case ! 

I switched to the Brave browser recently, which is based on Chrome, but has some tweaks to block some requests that it deems inappropriate. 

Out of curiosity I switched back to the Chrome browser to try adding Slack, and this time it worked.

 

Hope this helps other people,

Vincent from Vnited

Garrett Atlassian Team Aug 31, 2021

Hey @vincent thanks for the update! I saw a similar report from someone using Brave and they were able to successfully connect Slack by using another browser temporarily.

I'll share another comment suggesting some browser troubleshooting steps for other affected users.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Trello

Taco Tuesday: New years' resolutions with Trello

Congratulations to @Laura Holton , our latest winner of Taco Tuesday! And thanks to @Kristján Geir Mathiesen for sharing the picture of Taco having fun with his new friend  B...

2,304 views 28 40
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you