Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Trello - Unable to connect to a different Jira URL with power up

On Trello, I am unable to link to a new URL using the Jira power up.

I had a different URL previously (e.g. which was working fine, but now we have changed our instance of jira to I cannot get this to work with Trello.

I go to 'Connect to another JIRA' on Trello and after pasting the URL and hitting connect, I receive

"We're enabling the Trello integration inside your JIRA"


I have tried removing all previous links to JIRA stories from my non-archived cards, but this hasn't worked either. I have also tried disabling/reenabling the power up and removing all personal data (but it seems to still remember the old URL...)



Any assistance would be appreciated!


Thanks, Luke

1 answer

0 votes
rich Atlassian Team Jul 18, 2017

Hi Luke. Would you mind sending your details to our support team? We'll need more detailed info such as your actual JIRA Cloud URL to diagnose further. I suspect it has to do with the fact that your subdomain has changed.

Thanks Rich, after you had contacted me saying that some changes had been made it was now possible to add the JIRA Cloud URL. However, I am unable to remove the old link from appearing as an option when adding a story to a trello card but this is of a lower priority.

rich Atlassian Team Aug 07, 2017

You should be able to remove unwanted connections from the Power-ups' "Edit Settings" menu:


Hi@rich! I am currently experiencing this same issue. The integration has been working smoothly for months but is now failing. I've attempted to reconnect the integration several times on different boards with the same result = "we're enabling the Trello integration inside your Jira. Please wait..." indefinitely.

rich Atlassian Team May 30, 2018

Hi @Rebecca Blackburn. Thanks for reaching out. We've identified the issue and are currently deploying a fix. Sorry about that.

Hello, colleagues. 

I have the same issue. Could you help me to resolve this? 

While I am trying to connect jira to trello (using Power-Up) I am receiving the following message: 

"Error while validating tenant and addon enabled"


I have the same problem. Disconnected and reconnected several times. Either stuck on screen that says 

We're enabling the Trello integration inside your JIRA

or message 

Error while validating tenant and addon enabled

Yes I am getting the same issue

Same issue here:

Error while validating tenant and addon enabled

 Any solutions yet? 

Did anyone finally manage to solve it? Should I wait or should I conntact the support? 

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Trello

A Trello template to help you clean up your Confluence Space

Calling all Trello + Confluence users! We're celebrating all things Work and Wellness in our Confluence collection, where our team has been sharing activities to create more mindfulness around the ...

924 views 4 13
Read article

Atlassian Community Events