Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Trello: How do I change the due date time format to 24h?

fmjansen September 14, 2018

When setting a due date, the time is displayed in the 12h format (i.e. using AM and PM; shown in screenshot). How do I change this to the 24h format?

Screen Shot 2018-09-14 at 19.09.10.png

5 answers

1 accepted

1 vote
Answer accepted
Alexis Robert
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
September 14, 2018

Hi @fmjansen

 

you can have the time displayed as 24h format by changing the language from English (US) to English (UK). This will also change the way dates are displayed, but if you're fine with that it will achieve what you want.

 

Let me know if this helps, 

 

--Alexis

fmjansen September 14, 2018

Ooh, even better! I didn’t even notice the date format before, but this is what I wanted. Thanks!

Диди August 8, 2022

I have Russian set as my language, but the time is in 12h format. We use 24h format. Please change the time format for Russian to 24h or allow to customize the time/date format.

Like Niels Stor Swinkels likes this
Katrina Rozentale April 6, 2023

this doesn't really work

Like Niels Stor Swinkels likes this
8 votes
Jan Frederiksen June 21, 2022

It seems a bit inflexible not being able to change the date format independently of the language. I'm sure there are plenty of US English people who'd prefer a yyyy-mm-dd date format, or Danish people who'd prefer the first day of the week being Monday.

7 votes
Ionut S. February 10, 2023

I don't understand why there aren't more people complaining about this, it's an impediment to productivity to keep changing from AM to PM every time

2 votes
Vladimir Sidorov January 30, 2023

Changed to UK and still 12h format

axhussain April 28, 2023

Log out and back in again, and then you'll see the change.

Victor May 23, 2023

same for me, logging out doesn't work

0 votes
j_akramas July 26, 2023

TL;DR - Solution as of 2023 July 26 

Solution:

  1. Click on Profile Picture > Manage Account
  2. In the Atlassian Acount page, select Account Preferences
  3. Change language to English (UK)
  4. Log out and log in

Cheers!

Jan Frederiksen July 26, 2023

As this was already covered in previous replies above, I'll repeat that this is not a solution. It's a work-around.

Language should work independently from the time format.

Like Niels Stor Swinkels likes this
j_akramas July 26, 2023

Yeah, but it works. You can complain about the issue or you can just fix it. 

I repeated because there are still unaswered replies to threads stating that this is not working when it clearly do.

Jan Frederiksen July 26, 2023

Fair enough.

I was reacting mostly to the fact that this is still an actual issue (with or without a work-around available) from a leading company. And it rubs me the wrong way to call it a solution :-)

But thank you for the update, it's always nice when posts like these are followed up on.

Like Çiğdem Büyükaşik likes this
Niels Stor Swinkels
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 9, 2024

I agree with Jan. I'm perplexed that a company like Atlassian cuts corners like this. Don't they want to be the perfect product? You really can't have it like this..

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events