It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

In Trello, the Activity log on a card disappears when the card is moved to a new board!

This seems like a bug to me.  If you have a card on one board and then manually or through a Butler rule, move the card to a new board, all history of activity from the previous board disappears.  Anyone have a solution for this?  Is this something Trello is working to fix?

1 answer

1 accepted

0 votes
Answer accepted
Brittany Joiner Community Leader Sep 18, 2019

I still see history on mine. (see items below moving the card)

 

image.png

 

Can you show an example of where it's not working?

Interesting.  See if yours will retain activity such as creating a checklist and then complete one of the checklist items.  I received a response from Trello/Atlassian support that said it is working as designed and not a bug.  The reasoning is that they do not leave activity when you move to another board for security reasonse; because confidential information may have been included in the activity.  Is it perhaps becuase your board is "Public"?  Thanks so much for the response and help!

Brittany Joiner Community Leader Sep 18, 2019

Still works for me

image.png

 

I also just tried moving from a Private board on No Team, to another Private board on another team, and it still carried all the activity history.

Both the board it was on and the board it's moved to are private, so I don't think that's the issue. Are you moving your cards from public to private boards or vice versa? If you can show me an example of where you're moving from and to maybe I can better help diagnose.

I just created two new private test boards Test1 and Test2.  And moved a card that had two completed checklist items from 1 to 2.  I will attach the before and after card and you will see the activity history disappears.  I have tried it from private to private and public to private with the same result.  I appreciate your help.  Again, when I asked Trello they say the way mine is working is by design.  Odd, that yours is working as I would like it to.  I did work around the issud with a Butler rule to add a comment but would be nice if the checkbox completion record would work.Capture before the move.JPGCapture after the move.JPGThe top image is when the card existed on Board 1 and the 2nd images is after the move.

Brittany Joiner Community Leader Sep 18, 2019

Wow! This is truly strange haha. I dont understand what the difference is. I just did the same thing. Created Test 1 board, and Test 2 board, made a card on 1 and moved to 2. Both are private boards, and it carried over the history. 

Are both of those private boards on the same team? Or are they on different teams?

What's your trello username? Can I add you to those boards and see what it happens if you create a card on Test 1 and then move it to Test 2?

Alternatively if you'd rather add me to the test boards you created, I can try it there and see what it does for me. My trello username is britt_joiner . 

Yes, they are both the same team.  My username is mike_gibson.  Sure, I'd be happy to give it a try.  Thanks!

Brittany Joiner Community Leader Sep 18, 2019

Just added you to both the boards. Can you try out creating a card on test 1 and doing some activities then moving to test 2?

Brittany Joiner Community Leader Sep 19, 2019

@Michael Gibson the mystery continues!! I saw you tried to clone a card and said you couldn't see the history of the card you cloned on those boards, but I can see the history!

image.png

I just looked through all my personal settings to see if there's anything I have turned on that would be make this behavior work for me, and I don't see anything there.

I think we might have to share this with support. I know you've already reached out to them, but I think this gives them another data point if you can show them this thread and show them that I am in fact seeing the desired behavior. I wonder if somehow I have some sort of legacy behavior that's occuring or something. 

Just shoot an email to support@trello.com and link them to this thread and it should explain pretty clearly what's happening. Tell them they're welcome to reach out to me as well if they need to troubleshoot anything.

To add further to this, I looped @Devon_Henderson into this adventure and had her to do the same - create a board on Test 1, do some activity and move to Test 2. She has done that and we can both see all the activity history, and she can see the activity history for her cards, my cards, and your card post move. 

Definitely reach out to Trello support on this one and feel free to CC me on that email (brittanyjoiner15 at gmail.com) - I'm really curious what's going on here. Also let them know if they'd like to join these test boards where we've recreated the situations, here's the links: Test 1 and Test 2.

Hope they're able to help here as this truly is a mystery!

Like Devon_Henderson likes this

Thanks Brittany and Devon for your help looking into this!  I have forwarded a link to this thread as you suggested to trello support and will let you know what their response is.  Hopefully you will not end up loosing this functionality if it is something you use. :)

Brittany Joiner Community Leader Sep 19, 2019

Hahah not something I use too regularly, so I won't mind. But can't wait to figure out what's going on here. 

Like Michael Gibson likes this
Brittany Joiner Community Leader Sep 30, 2019

@Michael Gibson any update from support on this?? I've been dying to know!!

Yes, they are not able to duplicate it and have asked me to try a few things (e.g. different browswer, incognito or private browsing...)  I haven't' tried it yet but hope to today.

I'm typically in chrome.  Is that what you use?

Not sure what has changed but I can no longer duplicate the issue.  Thanks for all your help in trying to resolve a mysterious bug.  Now if I complete a task on one board and move it to another, it maintains the activity history--which is what we needed and why we created a Butler rule to compensate for the issue.  Thanks again and have a great day!

Brittany Joiner Community Leader Sep 30, 2019

@Michael Gibson so strange! And yes i typically use Chrome. 

Well, glad that it's working as intended now... regardless of the path we took to get there! 

Brittany Joiner Community Leader Sep 30, 2019

@Michael Gibson can you accept this answer if we're good here, please? That way rest of the community knows it's been addressed!

Like Michael Gibson likes this

Sorry I am new to this forum.  To "accept" do you mean to "Like" it or is there a place to offically accept and close out the thread?

Brittany Joiner Community Leader Oct 02, 2019

@Michael Gibson no worries - that's a good question! Up at the top, just below your qusetion, where I first replied, you should see a button that says "Accept Answer"

 

image.png

Let me know if that's not showing up... then we'll have a whole new bug to work through! 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Trello

Develop a new Habit during Lockdown

If you had to thrive a new habit during a lockdown, what would it be? Trello

1,598 views 14 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you