Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Getting "This board has reached its Power-Up limit" message on a NEW board with NO power ups? Edited

Hi 

I've just tried assigning a Power-up to some of my boards and I keep getting the message. "Get "This board has reached its Power-Up limit" even though there are no Power-ups assigned to the boards. I also tried creating a completely NEW board, yet I'm  still getting the same message.

Can someone shed some light as to why this might be happening? 

Kelly

1 answer

0 votes
Manu Atlassian Team Oct 15, 2019

Hi Kelly,

 

On free accounts, you can only enable 1 Power-Up on your boards and the message "This board has reached its Power-Up limit" is automatically displayed the moment you add one to the board which can be confusing but the Power-Up should have been added to the board.

If you're still not seeing your Power-Up on the board after adding it, could you reach out to us at https://trello.com/en/contact so we can have a closer look?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Trello

Develop a new Habit during Lockdown

If you had to thrive a new habit during a lockdown, what would it be? Trello

1,656 views 16 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you