Cannot download

Purchased new HD-8 recently. Tried to download Trello and just keeps trying to download. Never actually downloads. Called Amazon. They cleaned data/cache from several apps. Tried again. Still does not download. They said I needed to contact Trello. Not there problem. Everything working just fine on adroid phone and Chromebook

1 answer

0 votes
Francis Peixoto Community Champion Apr 23, 2017

Sounds to me like a very isolated issue. Have you tried logging of your account and back in? That usually helps on the Google Play store. 

Have tried that. Amazon tried it as well. Didn't seem to work. Appreciate your help! Will contact Trello in the AM and see what we can do.

Went back and downloaded as apk file. Seems to work. 

Suggest an answer

Log in or Join to answer
Community showcase
Bridget Sauer
Published Feb 02, 2018 in Trello

Atlassian User Groups: Trello edition

You’re invited to our first ever Trello User Groups   Good news for current and aspiring Trello enthusiasts! We’re launching Trello User Groups so that you can network, share ideas, solve ...

1,136 views 7 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot