It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot create buttom with Butler in free plan Edited

The "Butler Features and Quotas" says I can create 1 card button and that moving cards is allowed. However, when I try to create one, I get the message "Free plans are limited to one command of each type".

I have only the action "move the card to the top of list XXX" included. Tried disabling both "Enabled by default" and "Close card" options, to no avail.

What am I doing wrong?

Thanks in advance.

1 answer

1 accepted

0 votes
Answer accepted
Jireh Atlassian Team Nov 05, 2019

Hi Renato,

Do you have another Card Button command already made? If you already have a command for one of the types (Card Button, Board Button, Rules), then you can't create another command of that same type.

Hello:

I am sorry for my confusion. The button was already created, but I though that the "+ Create button" was the final confirmation of its creation, when in fact I was trying to create a second one. All solved now.

Thank you very much.

Like # people like this

I just experienced the exact same confusion. Thanks for posting your comment. Saved me some headaches.

Like Renato Saboya likes this

Hi, I have the exact same problem, except I don't no other Card/Board or command, and it still says the same thing.  

"Free plans are limited to one command of each type"

https://i.imgur.com/7ed0wQg.png

Any ideas? Thanks.

Hi @Hak Jenkins , your image shows you currently have a Card Button command called "Move To Done". If you already have a command for one of the types (Card Button, Board Button, Rules), then you can't create another command of that same type on the Free Plan.

Really appreciate you getting back to me.  

I can't find any tutorial or article that show's how to do it as all the UI (old) is different and even the Trello tutorial does multiple rules. I recorded a video to show I have done the most minimal actions I can that Trello would let me. Either doing it manually or as in this video following the "Wizard" Automation Tips. 

I can't think of less minimal steps not create more than one command. But surely there has to be ONE command. Otherwise, it would just be an empty button. But what is that one command that does the only thing I want, which is a button to move to "done" list.

I am using Trello everyday and just discovered this and would like to implement into my work-flow. If I still doing it wrong, then I would greatly appreciate a few lines of instructions of what I SHOULD be doing that just contains One command. 

Look forward to your advice. Thanks again for your help.

https://www.dropbox.com/s/im4dz9urik8bz22/LCpyeotZp4.mp4?dl=0

@Hak I think there might be some confusion here. The moment you click the green "save" button, the button is created. The reason the "create button" gives you that error is because you already have a card button called "Move to Done", and you cannot create another card button without deleting the first one.

Let me know if you need any more clarification

Jireh

Thanks again for the reply.

I am sorry there might be confusion, the problem is I don't know where that is, and I am trying to be concise as I don't want to waste your time.

That's why I showed you the video. I thought I was showing you that;

i don't have a button called "Move to Done"

and I can't create one unless I click the green "save" button.

In the video, I actually showed you deleting any buttons I have, and demonstrated both in the [Card Button] and [Board Button] folder's are empty. Where is it that I am supposed to have created this "Button"?

So unless you can direct me to where this "button" is OR show those few steps the moment we get into butler. OR how in actual fact are we meant to create this "One" button. I really appreciate you taking your time looking into this and all your help.

 

Hak

Okay, I'm going to go step by step of what I saw in your video, with timestamps:

0: I see you have a card button created called "Move2Done"

07: I see you remove (i.e. delete) that card button.

25: You go to the Automation tips and click "add" on one of the suggested buttons. This takes you to the button creation screen (which is the same screen you would go to if you pressed the "Create Button" button)

28: You're at the "Create A Card Button" screen (which as I said, is the same screen you'd hit if you pressed "Create Button" from the Card Buttons tab). You give the button a name "to done"

47: You press save. You return to the Card Buttons tab and you see the button "to done", which you just created. (At this moment, if you wanted to, you could close Butler and check any card on the board. You will see that the card button you just created is there).

51: You press the "Create Button" button. However you get an error saying "Free plans are limited to one command of each type". That is expected, because you just created a card button, and you are attempting to create another one. On the free plan, you cannot create another card button if you already have one created.

 

Does all that make sense? To clarify, your question is why are you getting the "Free plans are limited to one command of each type" error, right? I hope my explanation cleared up why you are getting that error.

Like Renato Saboya likes this

Hi Hak:

It looks like you're doing the exact same mistake that I did. In your video, after you clicked "save" your button is already created. You don't have to do anything else, you can go to your board and start using it.

The problem arises because we are given the impression that we have to confirm the creation of the button by clicking in "Create button", but this is not the case. This tells Trello to create another button, and since you already have one, it doesn't let you do that.

I guess the origin of this misunderstanding is that when you remove the button in the start of the video, the confirmation dialog asks if you want to remove the command, which, as far as I can tell, is not correct. It should ask if you want to remove the button.

Notice that in the page "Create card button", you type a name and save it, and then this name shows as a button in the page "Card buttons". You already accomplished what you wanted, you just have to go back to your board and use the button. Open any card in the board for which you enabled the button and search for it under the "Power up" section on the right.

Hope this helps.

Like Jireh likes this

Thank you so much Jireh and Renato for your help.

 

Hak

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Trello

Develop a new Habit during Lockdown

If you had to thrive a new habit during a lockdown, what would it be? Trello

1,484 views 12 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you