Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Can't invite a new member to our workspace


I sent an invitation to a new user for our workspace in Trello. We have a Premium subscription.  When the user visits the link, it say's the page is not found and that the workspace might be private, then asks him to "login", only he can't log in without a user account.

I then tried sending an invite with a link. When he clicks on the link, it says he already has an account. I looked in my workspace and found his name with a @ symbol in front of it and showing it's status as "virtual". I deleted the name from the workspace, but he still cannot create an account.

He is in our organization and has NEVER signed up for Trello before.  I have invited other members before with no issues.

What's going on? Any ideas?

1 answer

0 votes
Alex Waite
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Oct 18, 2022

Hey @Paul Eschenbach - welcome to the Community!

Have you tried asking this user to sign up for Trello themselves first at

Then, add them to your workspace with their email or username as opposed to sending them an invite link? 

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events