Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Automation butler error: "A possible loop was detected"

Andre Santos May 4, 2023

I have created the following rule and it is generating the error: A possible loop was detected.


when custom field "g-nm" is set, clear custom field "g-nm", lookup a card titled "{cardfirstmemberusername}" on board "Board Proc Ref v1", and post message "*<@{foundcarddescription}>*:\n\n{customfieldvalue} *<{triggercardlink} | Card {triggercardname}>* Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation *{triggercardlistname}*." to Slack channel "#action-trello" in workspace "MyCompany" as Butler


I don't understand why, once I don't see any looping in it.


I tried moving clear custom field "g-nm" to the end of the rule, but the error continues. I don't have any other rule that is triggered by the field "g-nm". I do have other rules with actions to set g-nm custom field, but they are triggered by moving a card to a specific list.

1 answer

0 votes
Dreamsuite Mike
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
May 4, 2023

Hi @Andre Santos 

Your command looks sound to me

Are you sure the loop error is coming from this automation?

When there is a loop error, the error will report on all automations that cause it so it could be another automation. 

There is no easy way to diagnose issues like this other than eliminating possibilities.  

1 thing to try would be to disable the other automations so only this one is enabled and test it, then enable the others 1 by 1 until the error re-occurs.

Andre Santos May 6, 2023

Hi @Dreamsuite Mike ! Thanks for you answer. I was going to try what you said and the error was gone. I ran the automation and the other automations a few more times but the error didn't come up again. Then I created a new board when turned on the automations. After a few runs, I got the same Looping error then didn't get it again. Maybe it's a bug. 

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events