Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,294,213
Community Members
 
Community Events
165
Community Groups

Automating copying card to another board when placed in a list

I am trying to copy a card from one board to another board when I place it in a particular list. I am using the automation to set up this rule:

when a card is added to list "Design" by anyone, copy the card to the bottom of list "Design Requests" on board "Design Tasks"

The rule is enabled on the board where the "Design" list is located. When I try to move or create a card in the "Design" list, this is the message I get in the usage logs:

Tuesday, April 12, 2022 3:51 PM
Running command on board.

I can't find a board called "Design Tasks". Is the board name spelled correctly?

The command finished running.

This doesn't make sense though because when I created the rule, I picked the board name from the drop down, so I didn't even type it in. So it should know that it exists, correct? I am also a member of both boards. Maybe a permissions problem? I don't know how to fix this... please help! Thank you!

1 answer

Your rule sounds the same as mine

cardcopy.png

And my rule works every time.  Is it possible someone accidentally changed the destination board name?  Maybe accidentally misspelling a word? 

You could also try deleting and recreating the rule from scratch, I've run into similar issues on other automations and oddly enough simply redoing it from the beginning has fixed some issues.

I've tried removing and deleting the rule multiple times, it still doesn't work and gives me the same message:

Running command on board.

I can't find a board called "Design Tasks". Is the board name spelled correctly?

The command finished running.

I've also tried enabling the rule on both boards. Also doesn't seem to help. 

Mine seems to look exactly like yours, the only difference is that it is "when a card is added <list name> by anyone", mine has the "by anyone" at the end. 

Max Egert I'm New Here May 17, 2022

Hi Amber, 

 

Were you ever provided a resolution to your issue? I am having the same problem with my automation and cant seem to find the root cause. 

 

Thank you!

Hi Max,

Unfortunately no, Bot's suggestion did not work for me. I ended up just copying it over manually each time :/

Max Egert I'm New Here May 18, 2022

I was able to correct the automation by changing the board name to one word. Not sure why this fixed it but it did :). Thank you for your feedback!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Trello

Taco Tuesday: New years' resolutions with Trello

Congratulations to @Laura Holton , our latest winner of Taco Tuesday! And thanks to @Kristján Geir Mathiesen for sharing the picture of Taco having fun with his new friend  B...

2,296 views 28 40
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you