User parameters rendering glitch?

This is on a newly initialized confluence site, to try to get a clean test for the functionality..

I added the PlaySQL Spreadsheets plugin, created a spreadsheet, and then a query for that spreadsheet.

To the query, I added a User Parameter, expecting the user parameter dialog from the query creation page to appear so that my user can enter their value. Instead, the dialog doesn't appear, and the playsql query widget is missing the red upper left cell, and otherwise looks strange.

This second screenshot is the same query with a default value put into the User Parameter widget. But still no place for the user to add their value.

Is this a known bug? or am I doing something wrong? Is there a version I can roll back to that works properly?

2 answers

This widget could not be displayed.

Hi Michael,

Using the Query macro, user parameters can only be set in the macro parameters (...)

An update on 14 Nov 2014:

Play SQL Spreadsheets 2.8 is out! It includes the ability to display a form above the query with user parameters. Thank you for your suggestion!

User Parameters View.png

Hmm....

I'm not able to change the user paramater in the macro editer when I edit the page. It only lets me change the user param when editing the query itself, which changes the user param for all instances of the query.

Am i doing something wrong?

This widget could not be displayed.

Adrien, as soon as we upgraded to Confluence 5.6.3, we started having this same issue.  We are used to having User Parameters integrated in many of our queries (and editable in the macro editor).  Now, however, there is no field in the macro editor that allows me to change the user parameter.

image2014-11-4 21:42:12.png

Correct, that's a problem. I'll start working on this today and I will deliver the fix within the week. Sorry for the inconvenience. NB: Since many users request to change parameters when one views the page, the next major version will display a form above the query so users can change parameters. Is it good news for you?

Thank you! And Yes, that is good news about the form above the query ... as long as we have the ability to remove the form (and just edit the User Parameter within the macro, as we have been up to now), as there would be times I wouldn't want the User Parameter to be so visible to most of our users.

As you've probably seen I've published version 2.7.3 with the fix.

Great, thank you; when I see it show up as an update in my "Manage Add-ons" area, I will definitely install it.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Monday in Teamwork

The tools we make for teams? We use them every day at Atlassian to get shit done (and it works).

I’m Jess, a Product Marketer for Jira Software Server and Data Center, and now a huge fan of our products. Read on for a 90 day, new-hire perspective on what it’s like to standardize on the Atlassian...

43 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you