Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Trying to create a metric for a source:Datadog results in no change or information

I am attempting to add a Datadog metric for Statuspage.  As far as I can tell, the third party datasource is properly linked, and when I copy a query from one of my monitors, nothing seems to be happening when I attempt to click the "Add metric" button.  I do not see an error providing me information about an invalid metric or query, nor does it inform me that it cannot handle that query.

Does anyone have any advice on this particular issue?

1 answer

1 accepted

1 vote
Answer accepted
Jesse Klein Atlassian Team Oct 28, 2021

Hi there,

This is Jesse from the Statuspage support team. Welcome to the community and thank you for the question about the Datadog metrics. I would actually double check that your API and application keys are set correctly. I know that we currently have an open issue right now where you can type anything in there and it will consider it valid so if anything is off, it will look fine but no data will come through.

When you run the query, it should go through a process to grab the backfilled data so if you see nothing, either those keys are incorrect in someway or you are grabbing more than what is contained in the q section of your request: https://support.atlassian.com/statuspage/docs/add-a-datadog-metric/

Finally, please also check your URI that you are using. If you are not hosted on one of the listed sites in the URI, the requests will also not work. We are looking to add the others but currently, we only have the two that you see when creating the metric.

Hope that helps. Feel free to reach out if you have any other questions about this.

Regards,
Jesse

Oh!  I had not assumed it was allowing anything inside the connection.  I had placed the ID and key of my Application API key, and that was the issue.  Swapping to both an API Key and an Application Key fixed it. 

For anyone else who might have this issue, you must supply both an API Key, and an Application Key for Datadog. 

Like # people like this
Jesse Klein Atlassian Team Oct 28, 2021

Awesome to hear that worked out! I will make sure to send the feedback to the team for when they make those fields mandatory and has them check for valid keys. Thanks again!!!

Regards,
Jesse

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Statuspage

New feature: Slack notifications for Statuspage

We're excited to announce the release of a long-requested feature on Statuspage. Now visitors to your status page can subscribe to get notified in Slack when you report an incident or maintenance. Th...

2,414 views 6 20
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you