Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

unable clone my repo

esekintela January 22, 2019

Hi

When I try to clone my repo I get this error that I don't understand

Command: perl.exe C:\Users\RQUINTELAW\AppData\Local\SourceTree\app-3.0.15\tools\svn.pl info https://fulcrumprojects.visualstudio.com/DefaultCollection/EnvioSeguimientoProyectos/_git/EnvioSeguimientoProyectos
Output:
Error: System.ComponentModel.Win32Exception: El sistema no puede encontrar el archivo especificado

Command: git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks ls-remote https://fulcrumprojects.visualstudio.com/DefaultCollection/EnvioSeguimientoProyectos/_git/EnvioSeguimientoProyectos
Output:
Error: fatal: ArgumentException encountered.
Ya se agreg� un elemento con la misma clave.
fatal: ArgumentException encountered.
Ya se agreg� un elemento con la misma clave.
fatal: Authentication failed for 'https://fulcrumprojects.visualstudio.com/DefaultCollection/EnvioSeguimientoProyectos/_git/EnvioSeguimientoProyectos/'

Command: hg identify extensions.hgext.hgsubversion=! https://fulcrumprojects.visualstudio.com/DefaultCollection/EnvioSeguimientoProyectos/_git/EnvioSeguimientoProyectos
Output:
Error: real URL is https://spsprodeus22.vssps.visualstudio.com/_signin?realm=fulcrumprojects.visualstudio.com&reply_to=https%3A%2F%2Ffulcrumprojects.visualstudio.com%2FEnvioSeguimientoProyectos%2F_git%2FEnvioSeguimientoProyectos%3Fcmd%3Dcapabilities&redirect=1&aadinmsa=true&context=eyJodCI6MiwiaGlkIjoiNjQyNTM4NzUtN2ViNC00ZTBkLWI3ZjMtNjhhZTU5MDhiODE5IiwicXMiOnt9LCJyciI6IiIsInZoIjoiIiwiY3YiOiIiLCJjcyI6IiJ90#ctx=eyJTaWduSW5Db29raWVEb21haW5zIjpbImh0dHBzOi8vbG9naW4ubWljcm9zb2Z0b25saW5lLmNvbSIsImh0dHBzOi8vbG9naW4ubWljcm...
abort: 'https://spsprodeus22.vssps.visualstudio.com/_signin?realm=fulcrumprojects.visualstudio.com&reply_to=https%3A%2F%2Ffulcrumprojects.visualstudio.com%2FEnvioSeguimientoProyectos%2F_git%2FEnvioSeguimientoProyectos%3Fcmd%3Dcapabilities&redirect=1&aadinmsa=true&context=eyJodCI6MiwiaGlkIjoiNjQyNTM4NzUtN2ViNC00ZTBkLWI3ZjMtNjhhZTU5MDhiODE5IiwicXMiOnt9LCJyciI6IiIsInZoIjoiIiwiY3YiOiIiLCJjcyI6IiJ90#ctx%3DeyJTaWduSW5Db29raWVEb21haW5zIjpbImh0dHBzOi8vbG9naW4ubWljcm9zb2Z0b25saW5lLmNvbSIsImh0dHBzOi8vbG9naW4ubWlj...' does not appear to be an hg repository:
---%<--- (text/html; charset=utf-8)


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

 

<html lang="en-US">
<head><title>

Azure DevOps Services | Sign In

</title><meta http-equiv="X-UA-Compatible" content="IE=11;&#32;IE=10;&#32;IE=9;&#32;IE=8" />
<link rel="SHORTCUT ICON" href="/favicon.ico"/>

<link data-bundlelength="508276" data-bundlename="commoncss" data-highcontrast="/_static/tfs/M146_20190115.21/_cssbundles/HighContrast/vss-bundle-commoncss-vKdM2Oatr5-B776BK8ztZFxdq8fuPNEwWImBm151isXU=" data-includedstyles="jQueryUI-Modified;Core;Splitter;PivotView" href="/_static/tfs/M146_20190115.21/_cssbundles/Default/vss-bundle-commoncss-v3gZ5nto-6mADno0zA6AxYKbxke8SQQAxxdCBQMfB_xw=" rel="stylesheet" />
<link data-bundlelength="115735" data-bundlename="viewcss" data-highcontrast="/_static/tfs/M146_20190115.21/_cssbundles/HighContrast/vss-bundle-viewcss-v0xLHJTbjvO_CeualJdyooJTeb_sWCY3tbGkf2EsvdfE=" data-includedstyles="VSS.Controls"
---%<---
!

 Any idea Please?

 

regards

2 answers

0 votes
esekintela January 24, 2019

Hi Ana

1.- SourceTree Version 3.0.15

2.- Yes

3.- I've been working without problems until one day I did not let myself do a push and so far

4.- Git in Azure dev ops: https://fulcrumprojects.visualstudio.com/DefaultCollection/EnvioSeguimientoProyectos/_git/EnvioSeguimientoProyectos

 

Thanks

esekintela February 4, 2019

Any idea please?

Luisdany Pernillo
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 14, 2019

Maybe you can try this:

 

https://stackoverflow.com/questions/45622960/sourcetree-remote-invalid-username-or-password

 

This part:

1. Do the above.
2. Close Sourcetree
3. Delete AppData\Local\Atlassian\SourceTree\passwd 
4. Restart SourceTree
5. Hurray!!!
0 votes
Ana Retamal
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
January 23, 2019

Hi Roberto!

Have you tried cloning from the command line? We'll need to know the result of this operation to understand if this is an issue in Sourcetree or with something else.

I also see some inconsistencies, it's not clear whether you're using Git or Mercurial, as I see this:

Command: git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks ls-remote https://fulcrumprojects.visualstudio.com/DefaultCollection/EnvioSeguimientoProyectos/_git/EnvioSeguimientoProyectos
.

.
.
Command: hg identify extensions.hgext.hgsubversion=! https://fulcrumprojects.visualstudio.com/DefaultCollection/EnvioSeguimientoProyectos/_git/EnvioSeguimientoProyectos


Could you clarify that, too?

Best regards,

Ana

esekintela January 23, 2019

Hi Ana

I have tried the same in other computer with another account and all is fine. I have tried to clone this same repo in my MAC with SourceTree Mac and all is fine.

I have uninstalled and reinstalled and I omit the Mercurial step.

I'm working with this repo without problems with Visual Studio Professional 2017 using the same account that Sourcetree does not accept

I don´t know how to clone with command line

Thanks

Ana Retamal
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
January 24, 2019

Hi Roberto,

So you're experiencing this issue only in a Windows computer, right? Please give us more information to help us troubleshoot this issue:

  1. Which Sourcetree version are you using?
  2. Have you tried wiping your Sourcetree preferences?
  3. Which steps are you following until you get the error?
  4. Is your repository is Git or Mercurial?

Let us know!
Ana

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events