"This is not a valid source path/URL" in SourceTree (Windows 7) when cloning repository from Github

I did an extensive search about this, but I wasn't able to find an answer. I am posting it here just in case someone could help. So here is the thing, I tried to clone a repository from github (for example: https://github.com/my-account/my-repository.git) using SourceTree in Windows 7, but the following was displayed:

1) This is not a valid source path / URL, so I click on Details...

2) It displays:

warning: github.com certificate with fingerprint xx:xx:xx:xx:xx... not verified (check hostfingerprints or web.cacerts config setting) abort:HTTP Error 406: Not Acceptable.

I found many similar issues related to clones using mercurial, from bitbucket or other platforms...but wasn't able to find an exact one using github as the repository service.

More details:

-The clone command in command line with Git worked well, and the repository was cloned successfully in a directory that I chose.

-When I tried to add it into SourceTree, it also didn´t work, displaying: This is not a valid working copy path.




2 answers

Ok, a friend of mine helped me to solve the issue. It seems that "fingerprint" is something related to Mercurial, and that is how he got to an answer. I only had enabled Mercurial support in SourceTree. In order to solve it, I clicked on Tools->Options->Git and then enabled Git on SourceTree!

Try to SSH to github using the SourceTree terminal. It should ask you if you want to trust the fingerprint. After that you should be able to clone.

Thanks for the quick answer Seth. I think I tried that before already and didn't work. I would like to test if cloning remotely works fine now. I think it does, but my repository is too big to clone it again using the Clone Repository option (I have in on local already, it took like 20 minutes to clone it through the command line). I am sure this could help someone in the same situation though. Thanks.

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

265 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot