Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,367,377
Community Members
 
Community Events
168
Community Groups

"Checkout in Sourcetree" button not working after updating to Mojave

I've been using Bitbucket in conjunction with SourceTree on this machine for several months with no problems.  After updating the OS to Mojave, the "Checkout in Sourcetree" button would only open Sourcetree but would neither fetch nor checkout the branch.  More recently, in the last couple of days or so, it won't even open Sourcetree.  Now today, fetching in Sourcetree does not retrieve branches created directly in Bitbucket.  It's as though they don't exist.

2 answers

1 vote
Manju Atlassian Team Nov 07, 2018

Could you please confirm the version of Sourcetree you are using? If its 3.0, we are aware of the issue and a fix is coming for it in 3.0.1 shortly.

Yes. 3.0 Thank you for the response. I look forward to the update.  Any idea yet when that may occur?

Running Sourcetree 3.0.1 under macOS 10.14.2 (18C38b) and still not able to checkout a branch. In fact not able to checkout any repository. Back do doing this manually. 

Like # people like this

I don't know if Atlassian folks are aware but everybody look to be impacted. 3.0.1 is buggy too.

 

As a workaround, downgrade to version 2.*

https://community.atlassian.com/t5/Sourcetree-questions/SourceTree-doesn-t-launch-when-clicking-quot-Check-out-in/qaq-p/586043

 

Download here:

https://www.sourcetreeapp.com/download-archives

Like # people like this

Hey guys,

Any news when this will finally be fixed?

 

Thanks

Jannis

Still not working in Sourcetree 3.0.1 and macOS 10.13.6.

The latest Beta works fine on my side: https://bitbucket.org/atlassianlabs/sourcetree-betas/downloads/ (see OSX_Beta_Latest.zip).

So I assume the next official version would be OK.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events