It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree doesn't launch when clicking "Check out in SourceTree" from BitBucket

Hi,

I reinstalled SourceTree following the recent security advisory email alert, but now it does not launch when I click the "Check out in SourceTree" button within BitBucket.

Can anyone help?

Thanks!

Baz

9 answers

1 accepted

5 votes
Answer accepted

Hi everyone! This was identified as a bug and was reported at SRCTREEWIN-7209. Please watch that ticket so you're notified of future updates. In the meantime, you can try the workaround explained in one of the comments:

  1. Open Tools > Options > General
  2. Uncheck Use this version of SourceTree for URI association
  3. Check Use this version of SourceTree for URI association

Let me know if this works for you :)

Cheers,

Ana

Excellent, thanks! That works for me!

UPDATE! 

It only works if SourceTree is already open. With the 1.9 version, it would also launch the app too

Thanks

Baz

Ana Retamal Atlassian Team May 16, 2017

Thanks for the update, Barry. I've added that information as an internal comment in the bug report. 

 

Posted Workaround doesn't works for me, I have to copy and paste the command manually in order to check out branches.

This worked for me.  Thanks!

Still not working in 2.1.10.0.

Still not working in 2.3.1.0

Still not work for me in 2.3.1.0 either.

Ana, I always come to this site when I have this problem. Thanks again. your solution works lovely.

This fixed the issue when this was broken with the release of major release 2.0. 

Unfortunately with the release of versin 3.0 this happened again, but this time I cannot find the option fo relate the URI with the app version.

 

macOs High Sierra (10.13.6) with Sourcetree 3.0.1

 

Any help will be greatly appreciated.

Thanks.

Like Chad Cook likes this

Yep same issue here

It is fixed for 3.x in the beta from 20th Dec 👏

You can get the Beta here:

https://bitbucket.org/atlassianlabs/sourcetree-betas/downloads/

I was using sourcetree version 3.0.0 when I tried to clone a repository from bitbucket it open sourctree app but didn't gave the windows to clone the repository it only open the first window. So I tried to downgrade to version 2.7.4 and now it works.

I can confirm the issue using Version 3.0 (200) on macOS. 

Its not working for me on version 3.0.0. on macOS. Did you change anything else to get it to work?

@Val as I mentioned in my answer, I downgraded to version 2.7.4 and now it works. You basically need to uninstall the version 3.0 and install version 2.7.4

Same issue, source tree 3.0.1 on OSX Mojave - downgrading sucks, how this crap gets through your QA is shocking

Like Maxim Putilin likes this

Same issue, source tree 3.0.1 on OSX Mojave - also do not want to downgrade.

same here with source tree 3.0.1 on OSX Mojave

Happy New Year,

I still face the issue.  😕

Sourcetree 3.0.1(205) on Mac!

Is finally fixed in the beta from 20th Dec 👏

You can get the Beta here:

https://bitbucket.org/atlassianlabs/sourcetree-betas/downloads/

I was able to get it working in Mojave by adding SourceTree to the list of apps that can "control your computer" in System Preferences. You'll have to use the unlock icon in the bottom left first.Screen Shot 2019-03-07 at 9.12.12 AM.png

same problem on mac

OS: high sierra

sourcetree: 3.0.1

ps it was working on el cap with sourcetree version 2.7.6

Issue is still here on 3.0.1 (205)

Like Steve Forbes likes this
0 votes
Ana Retamal Atlassian Team May 11, 2017

Hi Baz, do you have a local clone of the parent repository in SourceTree already? Keep in mind this is a requirement as explained at Check out a branch into a local repository. Does this happen with a specific branch, or with all of them?

Apart from that, can you confirm if SourceTree Launches when you try to open it manually?

If you're still having issues, let us know which version of MAc OS or Windows are you using so we can dig deeper into this.

Cheers!

Ana

Hi Ana,

Yes, SourceTree does launch, and I can use all of the functionality, such as cloning locally and everything else.

The only thing that doesn't work any more is its association with Chrome, when the "Check out in SourceTree" link is clicked within BitBucket

Check out in SourceTree.png

I'm running this on Windows 8.1

Thanks

Baz

Everyone on my team is having the same issue. I would love to have a fix for this too.

I'm using Windows 7

Sourcetree Version 2.0.20.1

Same issue for my whole team (different computers) these issue begun the past week (version 2.0.20.1)

Some developers I know aren't having this issue, they use a 2.1 version, but we don't know where they get it.

I am using Windows 10 and Chrome.

Just to confirm... this issue started as soon as I installed Sourcetree Version 2.0.20.1

i too have same issue but i can clone a whole repositiory but if i check out the same thing it does not pop-up the source tree 

 

this issue happening after i installing new source tree version 2.0.20.1 on windows 7

This issue continues on version 2.1.2.5

I've been having trouble with this for months and months but the most recent version of Sourcetree ate least gives me options instead of failing to open.

When i click the link from the website, Sourcetree asks me to create a new clone of the repo. Since I already have one, I assume that there is some confusion between the repo url on the website vs the url of my local repo.

So I compared the two URLs and the only difference was a casing one.

The url on the popup form that comes up when I click from the website is:

https://Dylan72@bitbucket.org/...

Whereas the one in SourceTree settings for my repo is:

https://dylan72@bitbucket.org/...

So I changed the setting in Sourcetree, and presto everything immediately started working again.

This has been driving me crazy for close to a year. And it was a case issue.

Incredible!

You solved my problem!!!

Thank you!

Now Attlasian will know how to fix it, all they have to do is don't use that Upper case at the beginning of the email.

It works.I am using source tree Version 2.5.50

The URL on the popup form that comes up when I click on the website is:

https://Dylan72@bitbucket.org/...

Whereas the one in SourceTree settings for my repo is:

https://dylan72@bitbucket.org/...

So I changed the setting in Sourcetree, and presto everything immediately started working again.

 

Thanks to Dylan Tusler

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,942 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you