Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

fatal: Authentication failed SourceTree 3.0

This seems to be a perennial issue, that apparently never got resolved fully.

I am currently using latest update of ST 3.0.17 and GitBlit as a remote host, but have been experiencing this problem on and off with many different versions.  OS is Windows 10.

Our office policy is to change passwords fairly frequently. every time this happens, I am unable to access remote repositories from SourceTree, and there is no way to update credentials from SourceTree. I have tried many solutions suggested by the community, none of them worked. Not even deleting psswd file in users. 

At random, I would get a chance to type in password. It does not work, and yes, I have confirmed that I can log in into my repository on GitBlit. 

One way or the other, this has been happening a lot, maybe it's time to add authentication update option to the repository settings? 

 

3 answers

This is what worked for me in the end:

Go to Tools -> Options- >Authentication; remove all accounts from there and re-add an existing one with proper credentials

Did you try update credential through Control Panel -> User Accounts -> Credential Manager like in this answer?

 I did, and it didn't work. In the end, I have removed my existing credentials and created new. It took several attempts, but it does work now. This is what I did: Tools-> Options->Authentication; removed all accounts from there (for some reason two are created) and re-added an existing one with proper credentials. Editing an existing account didn't work. Apparently I will have to go through this every time I am required to change my password.

This is a recurring problem for my entire team at work.

 

Deleting out the credential store either by going through the options or deleting the file on the backend is about the only thing that fixes it.

What file? I couldn't find any pwd file so tried all the credentials mgr options.

This is always an issue when my company forces a password update. In the old days I could blow away the pwd file and everything is good.

Now, with credentials manager crap nothing I do works and I simply don't know what to do other than abandon Sourcetree. I've tried all the recommendations (like 6 or 7) I found...nothing works.

 

Sourcetree is closer to a virus than a working app. In my opinion, if you can't get basic authentication right, especially after years of udpates.....you suck.

黄国斌 I'm New Here Feb 08, 2021

hi man,do this may help you.

firstly ,remove all your authentications

tools->options->authentication-delete all 

then click ok

Secondly,push your issue, choose manager-core sub-option when alert CredentialHelperSelector

it will show you like GitHub Sign  in- Sign in with your brower 

sign in ~ and may be the  helperSelector show up again ,do the same again 

you will see it done.

may it work for you

I tried a slightly different approach; Go to Tools->Options->Authentication and click the account with the issue.  At the bottom of the account information click Edit.  In the credentials section I'm set to OAuth as my authentication so i clicked the "Refresh OAuth Token" button.  After that i did a fetch on my repo and it worked again.  The token must have expired and it doesn't automatically renew. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,251 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you