How to update HTTP(S) credentials in sourcetree

Josh Love July 29, 2013

I'm using Stash, Sourcetree and Crowd. Crowd authenticates with our AD server. One of our users' AD passwords expired today and he went to do some work via sourcetree and it wouldn't let him communicate with stash properly

He set up the repo initially as HTTP when he first cloned it. It asked him for his username and password and he says he remembers clicking "Save/remember password"

Where can I have him reset/remove these credentials.

I've already worked around the issue by setting up SSH keys for this user, but I'm interested in what the fix would be. Presumably something via the command line, as I've been through every GUI screen I would think could have the setting in it.

24 answers

1 accepted

300 votes
Answer accepted
David Keck July 18, 2017

The only thing that worked for me was navigating to C:\Users\USERNAME\AppData\Local\Atlassian\SourceTree and removing the passwd file.

 

Once this file is removed, restart SourceTree and execute a fetch or something else that requires access to the repo in question. SourceTree will then prompt you for your password, rewriting the cached credentials.

 

I hope this helps. Shoutout to my buddy Nick for the assist.

 

If you're a macOS user, Auke states below that "you can find the password files per repo it in ~/Library/Application Support/SourceTree"

Rajesh August 10, 2017

This saved my time. Thanks!

Like # people like this
Josh Hed August 11, 2017

This worked great.  I've been digging into this for over an hour!  Thanks.

Like Adam_Domjan likes this
Rob Baragona August 13, 2017

This is also the only thing that worked for me.  Josh is lucky, i've spent about 5 hours on this between 2 different computer and creating new passwords!

THANK YOU!!

christopher_cook August 14, 2017

This worked for me as well.

Joseph Testa August 14, 2017

worked, thank you!!

Someone Unknown August 15, 2017

Only this solved "Authentication failed for" error for me. Thanks!

Ben Salvage August 16, 2017

Saved me too. Thank you!

Auke August 17, 2017

Alternatively, if you're a mac user, you can find the password files per repo it in ~/Library/Application Support/SourceTree

Like # people like this
jonghyun,yi August 17, 2017

Auke ter Horst You saved me! Thank you so much! I'm also mac user.

adanzilla August 17, 2017

Thank you David!!!

Silvio Di Silvestro August 22, 2017

It worked for me. Thx a lot !

Dan Ames August 22, 2017

Thanks David Keck! This saved me much pain and agony. 

Christophe Racine August 22, 2017

Cool, worked for me, thanks a lot !

HilcoVM August 23, 2017

Only way I could get access to my remote repo again. Thanks heaps!!

Loc_rabbirt August 30, 2017

Thank you so much, it's helped :).

Joe Wright September 22, 2017

This worked! Thank you very much.

jingjing September 25, 2017

Thank you so much! That's the only thing works for me. I have been spending too long on this.

jingjing September 25, 2017

Thank you so much! That's working!

Sebastian Raemsch October 1, 2017

This worked for me too! Thanks.

VenomBHz October 5, 2017

This was the solution!!! Spent some time trying to fix this... Thanks!!!

David Keck October 6, 2017

I'm so happy to see that this helped! Auke, I'll update the main answer with your macOS findings.

Sergiu Jardan October 9, 2017

Thank you. This worked for me.

Mauricio Salazar October 17, 2017

This was the answer for me to delete the C:\Users\USERNAME\AppData\Local\Atlassian\SourceTree\passwd file,  however, I also needed to change the username, and there was no way to do this through the sourcetree interface.

 

I found a file C:\Users\USERNAME\AppData\Local\Atlassian\SourceTree\userhosts    which had the wrong username.  I changed it there and restarted and then it was able to push github repos to the correct username.

Like # people like this
David Teo October 18, 2017

thanks David. your solution worked for Authenticate error.

fyi:

1) the failure ocurred on my SourceTree v2.3.x.x, when I updated my network Windows password.
2) When I ran ST v2.0.20.1 executable, no authentication error was encountered.
3) When I re-ran v2.3.x.x again, the authentication error resurfaced again.
4) Then, I came upon your solution and tried it, v2.3.x.x is working fine now. The original password file was dated ard 2 months ago, likely the last time it was changed before i upgraded to v2.3.x.x?

5) Before all these, i also tried the Tools-> Options -> Password change method.
It says authenticated after giving the correct password, but when I fetched my Repo, the authentication will fail. So apparently the passwd file in (4) could not be updated, which caused repo actions to fail?

Maybe it's a version bug?

Konstantin Pogorelov October 19, 2017

Yep! That is the solution. Thank you very much David! 

Zorobabel November 1, 2017

Thanks, this is the right solution

Lia Gelder November 6, 2017

Thanks David! This worked perfectly, only wish I had found your answer sooner!

Otto Harju November 7, 2017

Works for me. Credentials are not visible anywhere on the UI, not on the Tools->Options->Authentication tab, repository settings or Windows Credential Manager. Is there a JIRA ticket about this issue?

Shreya Rawal November 9, 2017

This worked!! :)

Horacio Filet November 16, 2017

Nice, it worked, thank you!!

kairaca November 27, 2017

Finally. Thank you!

Philip Chan January 19, 2018

This worked for me with version 2.4.7.0

Tracey Gibbons February 16, 2018

Thank you, and thanks to Mauricio Salazar for the userhosts info!

James Attwood March 9, 2018

Thank you so much! This worked for me with version 2.4.8.0 Windows 7 64bit

ronpackard March 28, 2018

Worked for me on the Mac.

Antonio_Sobalvarro April 4, 2018

Works perfect.

David Hubbard April 23, 2018

Thanks - this also worked for me - however as it's a central file - if you are using other accounts through SourceTree (e.g. BitBucket, GitHub) then you may want to just remove a single account line from the file rather than deleting the whole file.

Plus, as the User account used by SourceTree is also referenced in answers here - To specify a specific user account (which is not the default) I found that setting userid in the repo path (Settings > Remotes > Edit) e.g. http://myRepoUser@myrepo:3000/organisation/myrepo.git worked for an internal git server.  

Karl Zuvela May 9, 2018

This worked for me only after changing my Windows password again, as Sourcetree does not seem to accept passwords that begin with a special character such as '-'. Once I changed my password to begin with a letter then everything functioned as expected.

isac joseph June 3, 2018

THanks maan..

Olga Farber July 8, 2018

thank you so much! only this helped me, too

abnersouza July 15, 2018

Not working for tried many times to login to git in vsonline it was working just fine, but removed the keys from keychain, also reinstall and tried to clean up everything, when i type the credential it does not work and show the following on my mac:

fatal: Authentication failed for;

 

Even the credentials are correct

Manny Yu August 6, 2018

Works for me. Thanks much!

Krzysztof Gałązka August 8, 2018

Worked like a charm! Thank you!

Thyago Akira De Morais August 8, 2018

Great. Worked for me too. Thanks

Robert Pal September 11, 2018

Worked! Thanks!

oanselmogomes October 13, 2018

Funcionou pra mim! Obrigado! Thanks from Brazil!

lokt-par October 31, 2018

This worked for me. Thanks

nick November 24, 2018

also worked for me

ccino December 2, 2018

Thank you, David.  This worked for me.

Andrea Franchini December 6, 2018

Worked also for me.
Close Sourcetree, delete the password file, open Sourcetree, random fetch => correct login.

Pumpkins_ December 6, 2018

Worked for me, lost about 1 day of my life trying to fix it. 

jessicafreeney December 11, 2018

Was trying to fix this for about a week and this fixed it

Dean December 12, 2018

Saved my life. Thanks man!!!

Anssi December 12, 2018

This solved my problem. Thanks.

Ruben FitzSimons December 12, 2018

Many Thanks! Worked a treat!

Levin Purba December 19, 2018

Almost the end of 2018 and this problem still persist. Deleting the passwd file was the only way to get around. 

rc_kamran January 11, 2019

Thanks alot !

Alon Katz January 15, 2019

Thanks!

Uma Vijayakanthan January 19, 2019

Yup did the trick, the problem started when i changed my Atlassian password, after few days i opened source tree and i couldn't login with new password, it kept asking for password over and over again. 

Once removed the passwd file then it all worked! They should address this on the SoruceTree app.

 

Thanks

Uma

gargall82@gmail.com February 4, 2019

Thanks boy you are a great boy.

Pravin Bhat February 6, 2019

This helped me save time, thanks David!

Atlassian should fix this annoying issue.

Like Shawn De Alejandro likes this
Bandula Prasanna February 19, 2019

This really helped me getting resolved the same issue that wasted my time troubleshooting. 

Thank you very much!

khorshed_alam March 22, 2019

Million Thanks! You are rock!! 

Pablo Silvarrey June 11, 2019

Aleluya!

Like Jaque Nande likes this
Jaque Nande June 14, 2019

Thank you so much :D

apttus_neshah June 19, 2019

thanks it worked like charm

Vlad November 6, 2019

Thanks so much

MrDEV0 November 22, 2019

It works for me, thank you so much.

Géza KISS February 10, 2020

There is now a menu item for it (see answer below):  Tools > Options > Authentication

Chris D February 18, 2020

This half-solved my problem after upgrading to the latest version on Windows (3.3.8). I actually deleted all SourceTree folders under AppData just to be sure. Then I revoked my OAuth access to SourceTree from my Bitbucket account (through the website). Still wasn't working. I couldn't get past the "Registration" screen during installation that connects to BitBucket. It just stays on that screen after logging in and nothing happens.

Finally, I downgraded to 3.2.6 (what I had previously) and poof, everything was working again. I had to revoke/refresh my OAuth but at least I could open and work in SourceTree again.

nurulamin March 1, 2020

Thanks - it worked for me too

ALEXANDROS KESANOPOULOS March 11, 2020

It also worked for me.

If I change the password through UI it works for some hours and then it fails again probably because the passwd file is not updated.

Why does sourcetree uses credentials from two sources(windows credentials and passwd file)?

Like BartmanDilaw likes this
gs_luismoreno March 22, 2020

Worked for me. Impressive that this is still an issue after years, using Sourcetree version 3.34.

BartmanDilaw April 8, 2020

This save my day !

Koen Lesschen April 17, 2020

I can't believe that Sourcetree still did not fix this bug. 

Sebastián Salguero May 23, 2020

Great!

Jeffrey Gillingham July 16, 2020

Thanks for this, it fixed my issue and saved me lots of time.

Reema Dass October 6, 2020

Thankyou soo much this had worked for me and has saved a lot of time :-)

Nicholas Hibshman October 9, 2020

Worked for me too! 

Robert B November 26, 2020

almost 2021 and it is still the best option. thanks!

ALEXANDROS KESANOPOULOS November 26, 2020

Don't expect any good in 2020!

Roque BUGARIN January 5, 2022

Great !!! Thank you very much !!! 

Genesis Tabuena March 15, 2022

Best solution out there, definitely saved time!

Maxi Ramos June 1, 2023

Perfect! The SOLUTION

20 votes
Rich Newman April 4, 2016

I had a similar problem on Windows 10 when I wanted to use a new account on GitHub.  SourceTree was using cached credentials, and not displaying them on its internal dialogs, and I struggled to find a way to clear them.  I only worked out what was going on when I tried from Git Bash and had the same problem.  The credentials were definitely NOT on Tools -> Options -> Authentication.

The reason is SourceTree uses the Windows Credentials Store, so rather surprisingly you have to go to Control Panel.  Then Users and Accounts/Manage Your Credentials/Windows Credentials (it defaults to Web Credentials, which isn't what you want).  I had an entry for github.com under 'Generic Credentials'.  

I deleted this from the credentials screen and then tried to push from SourceTree, which now asked me for the new credentials and performed the push using them.

I don't know how easy Microsoft have made it for third-parties to at least show these credentials on their screens, but I would think this would be a reasonable enhancement for SourceTree to make.

HenrikS June 19, 2016

Same procedure should be followed on Windows 7 if just trying to change the password through Sourctree options fails.

Maksim Borisov August 23, 2017

Worked! thanks

Breno Santos September 6, 2017

Thx man, solve my problem.

Sudhanshu Dixit - HAM July 26, 2018

Thank you Rich, it worked for me, i was look at all the places for a solution. I had even removed the credentials from Web Credentials page. I saw there were 3 different credentials for git which when removed worked for me.

Holly_Yelland September 24, 2019

This worked for me, thanks!

Ancher Vijayakumar November 27, 2019

This worked for me, Thank you

Ancher Vijayakumar November 27, 2019

Untitled.pngDeleted these two lines and it worked.

Helen February 12, 2020

This is what I needed, thank you!

So frustrating though, trying to figure this out. I'd really like to see a wiki page about this...

gneocl May 12, 2020

This was really helpful! I spent a lot of time on this and you saved me even more, thank you!

Oppenlander January 27, 2021

Just had this happen to me too. I'm suspecting the root cause of this is when the Atlassian migration occurred from using login names to e-mail addresses. These can be used interchangeably on Atlassian, but is probably not accounted for in Sourcetree? I had two password files stored, associated with a username and an e-mail. Sourcetree was probably looking at the wrong one, and there's no transparency in the Sourcetree UI.

Tracy Lea Ogden April 23, 2021

2021 And this was the only thing that worked for me. Thanks for this!

14 votes
stevestreeting
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
July 30, 2013

If this is Windows, you do this in Tools > Options > Authentication, you can delete or update any passwords there.

On the Mac, you can do the same by starting Keychain Access and locating the password entries there.

Douglas Kazumi February 20, 2017

I had exactly the same issue on a Mac and could solve it using this answer.

sagan9 August 9, 2017

Had same issue on my mac, and solved it by changing credentials on Keychain Access. Thanks!

Breno Santos September 6, 2017

Thx man, solve my problem.

Frank Frank September 6, 2017

This doesn't work for me. When you hit delete, it will not do anything. When you hit edit, it will create a new entry with wrong information.

behelit October 9, 2017

This STILL doesn't work, even in the latest builds. Authentication says all good but when you pull/push you get authentication failure. It obviously stores the repo pass in some convoluted system that doesn't work.

Alexander Manoharan July 2, 2018

Thanks, it worked for me

Brett Shellhammer July 6, 2018

Thank you ... this worked great !!

Olga Farber July 8, 2018

Doesn't work in Windows, all says "authentication ok", but then pull gives again authentication error. Only thing that helped was to go and delete that file

Ian Kleinfeld September 25, 2018

This worked great for me -- I just deleted my password, then it asked for it next time I accessed the remote and all was good.

When I just "edited" it, it didn't work. 

João Martinho Marques December 23, 2020

Thanks man! It worked for me

Allyn July 8, 2021

This worked for me, thanks!

lme November 18, 2021

Thanks a lot !

5 votes
Daniel Brinca July 18, 2018

On SourceTree 2.7.6 you can easily reset your repo credentials, without having to mess manually with files, by following these steps:

  1. Open SourceTree preferences
  2. Go to the Advanced tab, to the far right
  3. Find the host name of your repo under "Default usernames for URLs which do not include one", on the bottom
  4. Press Edit, clear the username (leave it blank), and press OK
  5. Close preferences, do a Fetch on your repo, and enter the new credentials when prompted
Keri-Lyn Crovo October 11, 2018

I had to remove all the account information in here, have it prompt me for username/password (tried to clone empty repo from BBS in SourceTree), then I was able to connect enough to clone. What a pain!

Elizabeth Brealey November 16, 2018

This solved my problem!  Thank you!

Alvis Or May 7, 2019

Solved it for me on Mac. Thanks!

sangbpark94 February 17, 2020

This is the real solution!!!

2 votes
Ruedi Heimlicher November 13, 2018

Mac user: In High Sierra I found the Auth file in 

~/Library/Application Support/SourceTree

File: <username>@STAuth-github.com

I removed this file, restarted SourcTree and was prompted for the password in the push process.

Eddy Zhang December 13, 2019

Update DATE: Dec/13/2019

Recently I received an email from github:

You recently used a password to access an endpoint through the GitHub API. We will deprecate basic authentication using password to this endpoint soon. We recommend using a personal access token (PAT) with the appropriate scope to access this endpoint instead. Visit: https://github.com/settings/tokens

This works for me. Thanks!

Saad_ZARHLOUL March 10, 2020

HI all,

If after deleting the password file, authentication credentiels ...

still dosen't work, try to use terminal from sourcetree and do a fetch you'll have a window asking to enter your credentiels. and it will be working fine :)

0 votes
vishprak July 26, 2021

Simply worked. Thanks

0 votes
John McDougall May 12, 2021

That worked.  Thanks very much :-)

0 votes
niksman85 August 26, 2020

In search bar type Credential manager - Windows credentials - find and modify password.

It worked for me.

0 votes
leeanne99 June 11, 2020

It didn't work for me however I changed the 'Auth Type' in the Accounts to Basic and then manually added my new password. :)Screenshot 2020-06-11 at 16.25.18.png

0 votes
hithakshi_kulal February 6, 2020

Yup.. That worked!!! Thank you. 

Deleting git@STAuth-github.com file did the trick.

0 votes
hkmoca February 5, 2020

If you're a macOS user, Auke states below that "you can find the password files per repo it in ~/Library/Application Support/SourceTree"

 

Also, if you have issues changing the user name, in mac delete:

hostusernamemap file 

0 votes
K_Ravi_Kumar September 18, 2019

In my case I had multiple copies of Keys along with the updated one. I resolved by removing the old credentials from Keychain .

0 votes
duncan chiriga September 18, 2019

This worked for me (Sourcetree v3.2xx on Windows 10):

 

Problem: Failure to Authenticate:

Reason (why probably): because initial registration was done using Google Auth APIs, therefore...

 

1. Click "Remote Tab > Edit Accounts

2. Click on your saved bitbucket account

3. Click "Edit" again

..under "Credentials"

4. click "Authentication" and select "OAuth"

refresh and you should be set ..hopefully

0 votes
Siti Farah Ismail September 12, 2019

Maybe u guys can give this a try:

1. Goto Tools > Options

2. Click Authentication tab. There's sections(for me Accounts and Git Saved Passwords) for previously saved passwords.

3. Just click on the desired account. Details for the account will be shown with Edit and Delete buttons

4. Click Edit. It will prompt a window for you to put your password.

Done!

0 votes
Peng Huang July 10, 2019

Thank you David!!!

0 votes
Jeff Szczypinski May 22, 2019

I had to go to the C:\Users\<user>\AppData\Local\Atlassian\SourceTree directory and delete the cache folder and the passwd and userhosts files. Restart Source Tree, do a pull and it prompted me for the ID and PW.

0 votes
Xolela Masebeni February 21, 2019

You can also simply add your username in front of you repository address: e.g: git clone https://xolela@bitbucket.masebeni.co.za/scm/project_x.git

 

You will then be prompted to put in your new password on your next pull or push. From there you will not be prompted for a password until you change it again.

Laurence Henderson April 8, 2019

Can anyone tell me what the password filename is

David Hubbard April 8, 2019

As per the accepted answer (assuming you are on Windows) C:\Users\USERNAME\AppData\Local\Atlassian\SourceTree\passwd

krembo99 June 25, 2019

@Xolela Masebeni  this might work for a single repository but not for the hosted repositories dialog

0 votes
arich February 14, 2019

You don't have to blow away your whole password store.

In SourceTree navigate to the repository in question, click the Terminal button and type `git pull`. It will prompt you for the required credentials then you're good-to-go in the GUI as well.

Jeff Szczypinski May 22, 2019

That didn't work for me.

0 votes
Dean December 19, 2018

Just use Git Desktop. Tired of this bloody popup authentication modal!!!!!!!!!!!!!!!!!!!

Dan Ames December 19, 2018

I agree completely. I've recently switched to Git Desktop and love the simplicity and ease of it.

Like Dean likes this
0 votes
WEBCODER LTD (EU) December 4, 2018

Mac OSX 13.3.3, deleting password files doens't work for SourceTree 3.0.1 when trying to connect to Atlassian Bitbucket v5.11.1 self-hosted server. I managed to connect to Cloud BB and was only then able to get into the app's options otherwise it's completely useless. I still am unable to use it with the above BB server we're hosting so another broken cr*p from Atlassian.

0 votes
Reyelle Matanguihan July 11, 2018

This didn't worked for me. There is no password file under C:\Users\USERNAME\AppData\Local\Atlassian\SourceTree\

This is always what I get:

error.png

Bias Corp November 5, 2018

hanks guys. It was helpful

0 votes
armchairdeity July 3, 2018

Just for the sake of having complete use cases here... I had what I thought was the same problem. Turned out that our auth scheme had changed and we started logging in with just the username portion of our email addresses... so jrypkahauer instead of jrypkahauer@gmail.com. The real problem came when I added "jrypkahauer@gmail.com" to the list of default usernames for our domain.

So effectively I had inadvertently made it impossible for myself to use the correct username on the domain where our git repositories all live.

It took me nearly 4 months of fighting this to figure out why ONLY SourceTree forced me to use an old, invalid username but would still prompt for the password if it was provided. Today I went panel by panel thru the entire Preferences UI and finally found this one.