How to update HTTP(S) credentials in sourcetree

I'm using Stash, Sourcetree and Crowd. Crowd authenticates with our AD server. One of our users' AD passwords expired today and he went to do some work via sourcetree and it wouldn't let him communicate with stash properly

He set up the repo initially as HTTP when he first cloned it. It asked him for his username and password and he says he remembers clicking "Save/remember password"

Where can I have him reset/remove these credentials.

I've already worked around the issue by setting up SSH keys for this user, but I'm interested in what the fix would be. Presumably something via the command line, as I've been through every GUI screen I would think could have the setting in it.

8 answers

1 accepted

This widget could not be displayed.

The only thing that worked for me was navigating to C:\Users\USERNAME\AppData\Local\Atlassian\SourceTree and removing the passwd file.

 

Once this file is removed, restart SourceTree and execute a fetch or something else that requires access to the repo in question. SourceTree will then prompt you for your password, rewriting the cached credentials.

 

I hope this helps. Shoutout to my buddy Nick for the assist.

 

If you're a macOS user, Auke states below that "you can find the password files per repo it in ~/Library/Application Support/SourceTree"

This saved my time. Thanks!

This worked great.  I've been digging into this for over an hour!  Thanks.

This is also the only thing that worked for me.  Josh is lucky, i've spent about 5 hours on this between 2 different computer and creating new passwords!

THANK YOU!!

This worked for me as well.

worked, thank you!!

Only this solved "Authentication failed for" error for me. Thanks!

Saved me too. Thank you!

Alternatively, if you're a mac user, you can find the password files per repo it in ~/Library/Application Support/SourceTree

Auke ter Horst You saved me! Thank you so much! I'm also mac user.

Thank you David!!!

It worked for me. Thx a lot !

Thanks David Keck! This saved me much pain and agony. 

Cool, worked for me, thanks a lot !

Only way I could get access to my remote repo again. Thanks heaps!!

Thank you so much, it's helped :).

This worked! Thank you very much.

Thank you so much! That's the only thing works for me. I have been spending too long on this.

Thank you so much! That's working!

This worked for me too! Thanks.

This was the solution!!! Spent some time trying to fix this... Thanks!!!

I'm so happy to see that this helped! Auke, I'll update the main answer with your macOS findings.

Thank you. This worked for me.

This was the answer for me to delete the C:\Users\USERNAME\AppData\Local\Atlassian\SourceTree\passwd file,  however, I also needed to change the username, and there was no way to do this through the sourcetree interface.

 

I found a file C:\Users\USERNAME\AppData\Local\Atlassian\SourceTree\userhosts    which had the wrong username.  I changed it there and restarted and then it was able to push github repos to the correct username.

thanks David. your solution worked for Authenticate error.

fyi:

1) the failure ocurred on my SourceTree v2.3.x.x, when I updated my network Windows password.
2) When I ran ST v2.0.20.1 executable, no authentication error was encountered.
3) When I re-ran v2.3.x.x again, the authentication error resurfaced again.
4) Then, I came upon your solution and tried it, v2.3.x.x is working fine now. The original password file was dated ard 2 months ago, likely the last time it was changed before i upgraded to v2.3.x.x?

5) Before all these, i also tried the Tools-> Options -> Password change method.
It says authenticated after giving the correct password, but when I fetched my Repo, the authentication will fail. So apparently the passwd file in (4) could not be updated, which caused repo actions to fail?

Maybe it's a version bug?

Yep! That is the solution. Thank you very much David! 

Thanks, this is the right solution

Thanks David! This worked perfectly, only wish I had found your answer sooner!

Works for me. Credentials are not visible anywhere on the UI, not on the Tools->Options->Authentication tab, repository settings or Windows Credential Manager. Is there a JIRA ticket about this issue?

Nice, it worked, thank you!!

Finally. Thank you!

This worked for me with version 2.4.7.0

Thank you, and thanks to Mauricio Salazar for the userhosts info!

Thank you so much! This worked for me with version 2.4.8.0 Windows 7 64bit

Worked for me on the Mac.

Thanks - this also worked for me - however as it's a central file - if you are using other accounts through SourceTree (e.g. BitBucket, GitHub) then you may want to just remove a single account line from the file rather than deleting the whole file.

Plus, as the User account used by SourceTree is also referenced in answers here - To specify a specific user account (which is not the default) I found that setting userid in the repo path (Settings > Remotes > Edit) e.g. http://myRepoUser@myrepo:3000/organisation/myrepo.git worked for an internal git server.  

This worked for me only after changing my Windows password again, as Sourcetree does not seem to accept passwords that begin with a special character such as '-'. Once I changed my password to begin with a letter then everything functioned as expected.

THanks maan..

thank you so much! only this helped me, too

Not working for tried many times to login to git in vsonline it was working just fine, but removed the keys from keychain, also reinstall and tried to clean up everything, when i type the credential it does not work and show the following on my mac:

fatal: Authentication failed for;

 

Even the credentials are correct

Manny Yu I'm New Here Aug 06, 2018

Works for me. Thanks much!

Worked like a charm! Thank you!

Great. Worked for me too. Thanks

This widget could not be displayed.

I had a similar problem on Windows 10 when I wanted to use a new account on GitHub.  SourceTree was using cached credentials, and not displaying them on its internal dialogs, and I struggled to find a way to clear them.  I only worked out what was going on when I tried from Git Bash and had the same problem.  The credentials were definitely NOT on Tools -> Options -> Authentication.

The reason is SourceTree uses the Windows Credentials Store, so rather surprisingly you have to go to Control Panel.  Then Users and Accounts/Manage Your Credentials/Windows Credentials (it defaults to Web Credentials, which isn't what you want).  I had an entry for github.com under 'Generic Credentials'.  

I deleted this from the credentials screen and then tried to push from SourceTree, which now asked me for the new credentials and performed the push using them.

I don't know how easy Microsoft have made it for third-parties to at least show these credentials on their screens, but I would think this would be a reasonable enhancement for SourceTree to make.

Same procedure should be followed on Windows 7 if just trying to change the password through Sourctree options fails.

Thx man, solve my problem.

Thank you Rich, it worked for me, i was look at all the places for a solution. I had even removed the credentials from Web Credentials page. I saw there were 3 different credentials for git which when removed worked for me.

This widget could not be displayed.

If this is Windows, you do this in Tools > Options > Authentication, you can delete or update any passwords there.

On the Mac, you can do the same by starting Keychain Access and locating the password entries there.

I had exactly the same issue on a Mac and could solve it using this answer.

Had same issue on my mac, and solved it by changing credentials on Keychain Access. Thanks!

Thx man, solve my problem.

This doesn't work for me. When you hit delete, it will not do anything. When you hit edit, it will create a new entry with wrong information.

This STILL doesn't work, even in the latest builds. Authentication says all good but when you pull/push you get authentication failure. It obviously stores the repo pass in some convoluted system that doesn't work.

Thanks, it worked for me

Thank you ... this worked great !!

Doesn't work in Windows, all says "authentication ok", but then pull gives again authentication error. Only thing that helped was to go and delete that file

This widget could not be displayed.

Respectfully I must disagree with Steve's answer: It doesn't work at least for me because in Authentication there's no saved credentials for bitbucket.org and stash. I updated all my credentials for bitbucket and other vendors on the web, later i have to find out that i cannot log in to bitbucket in sourcetree, and there's no way for me to clear saved credentials. Except maybe wipe the local storage where sourcetree saves the preferences etc. but that can't the solution.

Edit: environment is windows.

This widget could not be displayed.

The credentials for windows are managed in the Windows Credential Manager in the Control Panel.

This widget could not be displayed.

Just for the sake of having complete use cases here... I had what I thought was the same problem. Turned out that our auth scheme had changed and we started logging in with just the username portion of our email addresses... so jrypkahauer instead of jrypkahauer@gmail.com. The real problem came when I added "jrypkahauer@gmail.com" to the list of default usernames for our domain.

So effectively I had inadvertently made it impossible for myself to use the correct username on the domain where our git repositories all live.

It took me nearly 4 months of fighting this to figure out why ONLY SourceTree forced me to use an old, invalid username but would still prompt for the password if it was provided. Today I went panel by panel thru the entire Preferences UI and finally found this one.

This widget could not be displayed.

This didn't worked for me. There is no password file under C:\Users\USERNAME\AppData\Local\Atlassian\SourceTree\

This is always what I get:

error.png

This widget could not be displayed.

On SourceTree 2.7.6 you can easily reset your repo credentials, without having to mess manually with files, by following these steps:

  1. Open SourceTree preferences
  2. Go to the Advanced tab, to the far right
  3. Find the host name of your repo under "Default usernames for URLs which do not include one", on the bottom
  4. Press Edit, clear the username (leave it blank), and press OK
  5. Close preferences, do a Fetch on your repo, and enter the new credentials when prompted

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

722 views 1 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you