cant initialise git before and now cant create branch

I was trying to initialize Git flow to my new project but it wasn't allowing me giving error. Then i uninstall and reinstall old source tree so now I cant see initialize Git flow option and its shows me all options New feature.....etc..

when i try to click create new feature its give me following error.

its same error when i was trying to initialize git flow.

 

sh.exe C:\Users\ashishtailor\AppData\Local\Atlassian\SourceTree\gitflow_local\gitflow\git-flow feature start Theme_creation
C:\Users\ashishtailor\AppData\Local\Atlassian\SourceTree\gitflow_local\gitflow\git-flow: line 73: /gitflow-common: No such file or directory
Completed with errors, see above.

 

1 answer

This widget could not be displayed.

Hi 

It sounds like the gitflow installation has become corrupted. I would suggest deleting the existing C:\Users\ashishtailor\AppData\Local\Atlassian\SourceTree\gitflow_local\ folder and re-installing Sourcetree.

"and its shows me all options New feature.....etc.."
From this it sounds like git flow init did run at somepoint.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

861 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you