Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,927
Community Members
 
Community Events
168
Community Groups

Your repository isn't properly configured (SourceTree)

My current SourceTree version is 2.4 (96) under MacOSX and since my last update of sourcetree (from 2.3 to 2.4), I get the error, see screenshot below, when opening any of my repositories.

Screen Shot 2017-02-21 at 16.25.07.png

  • If I click on "Show Accounts": I don't see any error in my repository configuration. Actually everything works fine (appart from this error window appearing)
  • If I click on "Repair" or "Ignore": it does not have any impact. the error window still appear the next time that I open the repository that I repaired.

I also get the Console log below :

01/03/17 11:06:37,482 git-credential-sourcetree[11201]:  SecOSStatusWith error:[-34018] Error Domain=NSOSStatusErrorDomain Code=-34018 "client has neither application-identifier nor keychain-access-groups entitlements" UserInfo={NSDescription=client has neither application-identifier nor keychain-access-groups entitlements}

 

Many thanks in advance for your help or hints to solve this issue,

Benoît

 

 

4 answers

The popup message is clear. To resolve this issue, click on Show Accounts from the popup or go to Preference -> Accounts. Change the protocol to https from ssh or vice versa as per what is supported by your bitbucket account.

Fixed for me, thanks!

0 votes
Manju Atlassian Team Feb 22, 2018

Please upgrade to the latest version of Sourcetree on macOS which is 2.7.1. We have made many changes around this area in the newer versions and believe this is addressed. 

I'm running version 2.7.1 (156), and the problem is occurring today.    Is there a newer version that actually fixes this bug?

I am coming from 2.7.1 to get away from an issue with persistent re-prompts for passwords (and then not working).  2.6.3 solved that issue but I'm seeing this particular issue now.  When might there be a newer version to solve both issues?

Manju Atlassian Team Apr 11, 2018

A new version of Sourcetree is available which has a ton of fixes for authentication issue. Please try OSX_Latest.zip from https://bitbucket.org/atlassianlabs/sourcetree-betas/downloads/ and report if you see any errors. 

Thanks,
Manjunath
Sourcetree Mac Developer

I just upgraded to Sourcetree 3.0 and this issue is still there

Guys, check my answer 

Like itsme_Drew likes this

Atlassian!!  Are you going to address this question, or not!!!????

Check my answer

I have also remove the access keys in the "Keychain Access" max osx application.

Then restarted SourceTree, I still have the same error.

Same issue here. 'repair' seems to do nothing, still get error next time I open the repo. Seems to have been introduced with latest SourceTree release.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events